码迷,mamicode.com
首页 > 其他好文 > 详细

uva10494 - If We Were a Child Again

时间:2014-05-10 08:35:56      阅读:339      评论:0      收藏:0      [点我收藏+]

标签:uva

Problem C
If We Were a Child Again

Input: standard input
Output: standard output

Time Limit: 7 seconds

 

“Oooooooooooooooh!

If I could do the easy mathematics like my school days!!

I can guarantee, that I’d not make any mistake this time!!”

Says a smart university student!!

But his teacher even smarter – “Ok! I’d assign you such projects in your software lab. Don’t be so sad.”

“Really!!” - the students feels happy. And he feels so happy that he cannot see the smile in his teacher’s face.

 

 

bubuko.com,布布扣

The Problem

 

The first project for the poor student was to make a calculator that can just perform the basic arithmetic operations.

 

But like many other university students he doesn’t like to do any project by himself. He just wants to collect programs from here and there. As you are a friend of him, he asks you to write the program. But, you are also intelligent enough to tackle this kind of people. You agreed to write only the (integer) division and mod (% in C/C++) operations for him.

 

Input

Input is a sequence of lines. Each line will contain an input number. One or more spaces. A sign (division or mod). Again spaces. And another input number. Both the input numbers are non-negative integer. The first one may be arbitrarily long. The second number n will be in the range (0 < n < 231).

 

 
Output

A line for each input, each containing an integer. See the sample input and output. Output should not contain any extra space.

 

 
 
Sample Input

110 / 100

99 % 10

2147483647 / 2147483647

2147483646 % 2147483647

 

 

 

 

 
 
Sample Output

1

9

1

2147483646

 


参考http://blog.csdn.net/zcube/article/details/8461546,使用c++实现,注意中间的变量的值范围可能超过int类型,为了防止截断,在=右侧保留long long类型变量rem

#include<iostream>
#include<string>
#include<sstream>
#include<cstdio>
#include<cstring>
using namespace std;

#define MAX 10000

int x[MAX];

string Div(string str, int y){
	int i;
	long long rem;
	stringstream s;
	string ans;

	memset(x, 0, sizeof(x));
	for(i = 0; i < str.size(); i++){
		x[i] = str[i]-‘0‘;
	}
	
	rem = 0;
	for(i = 0; i < str.size(); i++){
		long long temp;
		temp = rem*10 + x[i];
		rem = temp%y;
		x[i] = temp/y;
	}

	for(i = 0; i < str.size(); i++){
		if(x[i] != 0)
			break;
	}
	for(int j = i; j < str.size(); j++){
		s << x[j];
	}
	s >> ans;
	if(ans.empty())
		ans = "0";
	return ans;
}

string Mod(string str, int y){
	long long rem;
	stringstream s;
	string ans;

	rem = 0;
	for(int i = 0; i < str.size(); i++){
		long long temp;
		temp = str[i] - ‘0‘ + rem*10;
		rem = temp%y;
	}

	s << rem;
	s >> ans;
	return ans;
}

int main(void){
	string x, oper;
	int y;

#ifndef ONLINE_JUDGE
	freopen("f:\\infile.txt", "r", stdin);
#endif

	while(cin >> x >> oper >> y){
		if(oper == "/")
			cout << Div(x, y) << endl;
		else
			cout << Mod(x, y) << endl;
	}

	return 0;
}

uva10494 - If We Were a Child Again,布布扣,bubuko.com

uva10494 - If We Were a Child Again

标签:uva

原文地址:http://blog.csdn.net/u011863942/article/details/25003021

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!