码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1963:All in All

时间:2014-07-27 23:52:59      阅读:305      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   strong   io   for   

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 27707   Accepted: 11381

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

简单的字符串问题。。判断后一个字符串是否包含前一个。。好久没0MS  1A 了 。。。OTL。。。


#include<iostream>
#include<cstring>
#include<ctime>
#include<algorithm>
#include<cstdio>
#include<queue>
using namespace std;

const int maxn = 100000 + 50;
char a[maxn];
char b[maxn];

int main()
{
    while(scanf("%s%s", a, b)==2)
    {
        int x = strlen(a);
        int y = strlen(b);
        int t = 0;
        int judge = 0;
        if( y<x )
        {
            printf("No\n");
            continue;
        }
        for(int j=0; j<y; j++)
        {
            if( b[j] == a[t] )
            {
                t++;
                judge++;
            }
        }
        if( judge==x )
            printf("Yes\n");
        else
            printf("No\n");
    }

    return 0;
}





POJ 1963:All in All,布布扣,bubuko.com

POJ 1963:All in All

标签:des   style   http   color   os   strong   io   for   

原文地址:http://blog.csdn.net/u013487051/article/details/38178913

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!