码迷,mamicode.com
首页 > 其他好文 > 详细

HDUJ 2952 Counting Sheep 搜索

时间:2014-07-28 00:29:19      阅读:276      评论:0      收藏:0      [点我收藏+]

标签:c++   hduj   

Counting Sheep

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2039    Accepted Submission(s): 1342


Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I‘d gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.
bubuko.com,布布扣


Creative as I am, that wasn‘t going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.


Now, I‘ve got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I‘ve decided I need another computer program that does the counting for me. Then I‘ll be able to just start both these programs before I go to bed, and I‘ll sleep tight until the morning without any disturbances. I need you to write this program for me.
 

Input
The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.
 

Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints
0 < T <= 100
0 < H,W <= 100
 

Sample Input
2 4 4 #.#. .#.# #.## .#.# 3 5 ###.# ..#.. #.###
 

Sample Output
6 3
 



#include<iostream>
#include<cstring>
using namespace std;

#define M 105
char c[M][M];
int v[M][M];
int w[4][2]={1,0,0,1,-1,0,0,-1};
int n,m,ans;

void dfs(int a,int b)
{
	c[a][b]='.';
	for(int i=0;i<4;i++)
	{
		int xi=a+w[i][0];
		int yi=b+w[i][1];
		if(xi>=0&&xi<n&&yi>=0&&yi<m&&c[xi][yi]=='#')
			dfs(xi,yi);
	}
}

int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		cin>>n>>m;
		int i,j;
		for(i=0;i<n;i++)
			cin>>c[i];

		ans=0;
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
				if(c[i][j]=='#')
				{
					dfs(i,j);
					ans++;
				}

		cout<<ans<<endl;
	}

	return 0;
}


HDUJ 2952 Counting Sheep 搜索,布布扣,bubuko.com

HDUJ 2952 Counting Sheep 搜索

标签:c++   hduj   

原文地址:http://blog.csdn.net/hyccfy/article/details/38167773

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!