码迷,mamicode.com
首页 > 其他好文 > 详细

HDUJ 1042 N!

时间:2014-07-28 15:44:33      阅读:205      评论:0      收藏:0      [点我收藏+]

标签:java   hduj   

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53394    Accepted Submission(s): 15085


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
1 2 3
 

Sample Output
1 2 6




import java.util.Scanner;
import java.math.BigInteger;


public class yhrtr {

	public static void main(String[] args) {
		Scanner cin = new Scanner (System.in);
			 
		while(cin.hasNext())
		{
			BigInteger  s = BigInteger.ONE;
			int n = cin.nextInt();
			for(int i=1;i<=n;i++)
				s = s.multiply(BigInteger.valueOf(i));
			
			System.out.println(s);
		}
	}
}


HDUJ 1042 N!,布布扣,bubuko.com

HDUJ 1042 N!

标签:java   hduj   

原文地址:http://blog.csdn.net/hyccfy/article/details/38230899

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!