码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3652 —— B-number

时间:2016-04-14 01:16:33      阅读:110      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 

Description

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
 

Input

Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
 

Output

Print each answer in a single line.
 

Sample Input

13
100
200
1000
 

Sample Output

1
1
2
2
 
#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
using namespace std;

int len;
int a[12], b[12];
int dp[12][2][2][13];

int dfs(int u, bool is1, bool have, int mod, bool limit)
{
    if(u < 1)    return have && mod ==0;
    
    if(!limit && dp[u][is1][have][mod] != -1)    return dp[u][is1][have][mod];
    
    int maxn = limit ? a[u] : 9;
    int ret = 0;
    
    for(int i=0; i<=maxn; i++) {
        b[u] = i;
        ret += dfs(u-1, i==1, have||is1&&i==3, (mod*10%13+i)%13, limit&&i==maxn);
    }
    if(!limit)    dp[u][is1][have][mod] = ret;
    return ret;
}

int f(int n)
{
    len=0;
    while(n) {
        a[++len] = n%10;
        n /= 10;
    }
    return dfs(len, 0, 0, 0, 1);
}

int main ()
{
    int n;
    memset(dp, -1, sizeof(dp));
    while(scanf("%d", &n) != EOF) {
        printf("%d\n", f(n));
    }
    
    return 0;
}

 

HDU 3652 —— B-number

标签:

原文地址:http://www.cnblogs.com/AcIsFun/p/5389532.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!