码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2126 Buy the souvenirs

时间:2014-07-29 14:34:23      阅读:231      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   java   color   os   strong   

Buy the souvenirs

Time Limit: 10000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 927    Accepted Submission(s): 319


Problem Description
When the winter holiday comes, a lot of people will have a trip. Generally, there are a lot of souvenirs to sell, and sometimes the travelers will buy some ones with pleasure. Not only can they give the souvenirs to their friends and families as gifts, but also can the souvenirs leave them good recollections. All in all, the prices of souvenirs are not very dear, and the souvenirs are also very lovable and interesting. But the money the people have is under the control. They can’t buy a lot, but only a few. So after they admire all the souvenirs, they decide to buy some ones, and they have many combinations to select, but there are no two ones with the same kind in any combination. Now there is a blank written by the names and prices of the souvenirs, as a top coder all around the world, you should calculate how many selections you have, and any selection owns the most kinds of different souvenirs. For instance:

bubuko.com,布布扣


And you have only 7 RMB, this time you can select any combination with 3 kinds of souvenirs at most, so the selections of 3 kinds of souvenirs are ABC (6), ABD (7). But if you have 8 RMB, the selections with the most kinds of souvenirs are ABC (6), ABD (7), ACD (8), and if you have 10 RMB, there is only one selection with the most kinds of souvenirs to you: ABCD (10).
 


Input
For the first line, there is a T means the number cases, then T cases follow.
In each case, in the first line there are two integer n and m, n is the number of the souvenirs and m is the money you have. The second line contains n integers; each integer describes a kind of souvenir.
All the numbers and results are in the range of 32-signed integer, and 0<=m<=500, 0<n<=30, t<=500, and the prices are all positive integers. There is a blank line between two cases.
 


Output
If you can buy some souvenirs, you should print the result with the same formation as “You have S selection(s) to buy with K kind(s) of souvenirs”, where the K means the most kinds of souvenirs you can buy, and S means the numbers of the combinations you can buy with the K kinds of souvenirs combination. But sometimes you can buy nothing, so you must print the result “Sorry, you can‘t buy anything.”
 


Sample Input
2 4 7 1 2 3 4 4 0 1 2 3 4
 


Sample Output
You have 2 selection(s) to buy with 3 kind(s) of souvenirs. Sorry, you can‘t buy anything.
 


Author
wangye
 


Source
 


Recommend
威士忌


题意:求最优方案数。

具体贴个别人的博客,我就是看这个学哒。

http://blog.csdn.net/wumuzi520/article/details/7019131

AC代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <stdlib.h>

using namespace std;
int a[35];
int dp[35][505];
int mark[35][505];

int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
        }
        for(int i=0;i<=n;i++){
            for(int j=0;j<=m;j++){
                mark[i][j]=1;
            }
        }
        for(int i=0;i<=n;i++){
            dp[i][0]=0;
        }
        for(int i=0;i<=m;i++){
            dp[0][i]=0;
        }
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                dp[i][j]=dp[i-1][j];
                mark[i][j]=mark[i-1][j];
                if(j>=a[i]){
                    if(dp[i-1][j-a[i]]+1>dp[i][j]){
                        dp[i][j]=dp[i-1][j-a[i]]+1;
                        mark[i][j]=mark[i-1][j-a[i]];
                    }
                    else if(dp[i][j]==dp[i-1][j-a[i]]+1){
                        mark[i][j]=mark[i-1][j]+mark[i-1][j-a[i]];
                    }

                }
            }
        }
        if(dp[n][m])
            printf("You have %d selection(s) to buy with %d kind(s) of souvenirs.\n",mark[n][m],dp[n][m]);
        else
            printf("Sorry, you can't buy anything.\n");
    }
    return 0;
}






HDU 2126 Buy the souvenirs,布布扣,bubuko.com

HDU 2126 Buy the souvenirs

标签:des   style   blog   http   java   color   os   strong   

原文地址:http://blog.csdn.net/kimi_r_17/article/details/38236519

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!