码迷,mamicode.com
首页 > 其他好文 > 详细

HDU4883模拟

时间:2014-07-29 14:48:18      阅读:224      评论:0      收藏:0      [点我收藏+]

标签:暴力美学   模拟   

原题http://acm.hdu.edu.cn/showproblem.php?pid=4883

TIANKENG’s restaurant

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 443    Accepted Submission(s): 231


Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?


 

Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.


 

Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.


 

Sample Input
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00


 

Sample Output
11 6
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
//直接模拟,把每分钟的人数都确定下来,然后循环。找出答案

#include <string>
#include <algorithm>
#include <iostream>
#include <stack>
#include <queue>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;
#define N 1444
int ans[N];

int main(){
	int t,n,sum,a,b,c,d,f1,f2,i;
	
	while(~scanf("%d",&t)){
		while(t--){
			memset(ans,0,sizeof(ans));
			scanf("%d",&n);
			while(n--){
				scanf("%d%d:%d%d:%d",&sum,&a,&b,&c,&d);
				//memset(ans,0,sizeof(ans));
				f1 = a*60+b;
				f2 = c*60+d;
				//int i;
				for(i=f1;i<f2;i++){
					ans[i]+=sum;
				}
			}
			
			int max = -1;
			for(i=0;i<N;i++){
				if(max < ans[i]){
					max = ans[i];
				}
			}
			printf("%d\n",max);
		}
	}
	
	return 0;
}


 

HDU4883模拟,布布扣,bubuko.com

HDU4883模拟

标签:暴力美学   模拟   

原文地址:http://blog.csdn.net/zcr_7/article/details/38235147

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!