码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1151Air Raid (二分匹配,最小路径覆盖)

时间:2014-07-29 15:09:08      阅读:235      评论:0      收藏:0      [点我收藏+]

标签:二分匹配

Problem Description
Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town‘s streets you can never reach the same intersection i.e. the town‘s streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.

Input
Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town‘s streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.

Output
The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.

Sample Input
2 4 3 3 4 1 3 2 3 3 3 1 3 1 2 2 3

Sample Output
2 1
题意:给出有n 个十字路口,给出m个边,每条边都是单向的,要求用最少的人去从一个十字路口一直走向另一个十字路,有路就可以再走向下一个,要把所有的十字路口都要走过。
解题:跟据题意,就是求最小路径覆盖。最小路径覆盖=点数n-最大匹配数。
#include<stdio.h>
#include<string.h>
int n,map[125][125],vist[125],match[125];
int find(int i)
{
    for(int j=1;j<=n;j++)
    if(vist[j]==0&&map[i][j])
    {
        vist[j]=1;
        if(match[j]==0||find(match[j]))
        {
            match[j]=i; return 1;
        }
    }
    return 0;
}
int main()
{
    int m,t,a,b,ans;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(map,0,sizeof(map));
        while(m--)
        {
            scanf("%d%d",&a,&b); map[a][b]=1;
        }
        ans=0;
        memset(match,0,sizeof(match));
        for(int i=1;i<=n;i++)
        {
            memset(vist,0,sizeof(vist));
            ans+=find(i);
        }
        printf("%d\n",n-ans);
    }
}


hdu1151Air Raid (二分匹配,最小路径覆盖),布布扣,bubuko.com

hdu1151Air Raid (二分匹配,最小路径覆盖)

标签:二分匹配

原文地址:http://blog.csdn.net/u010372095/article/details/38231257

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!