码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 4257 Most Powerful

时间:2014-07-30 12:24:13      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:des   style   os   io   for   代码   ar   div   

Description

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22


题意:两个bomb相撞一个会消失并产生能量,求能产生的最大能量。

思路:dp[s]表示s状态下的能量。

AC代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <stdlib.h>

using namespace std;

int p[15][15];
int dp[1<<11];

int main(){
    int n;
    while(~scanf("%d",&n)){
        if(n==0) break;
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                scanf("%d",&p[i][j]);
            }
        }
        memset(dp,0,sizeof(dp));
        for(int s=0;s<(1<<n);s++){
            for(int i=0;i<n;i++){
                if(s&(1<<i)) continue;//s状态已经包含i;
                for(int j=0;j<n;j++){
                    if(s&(1<<j)) continue;
                    if(i==j) continue;
                    int t=s+(1<<j);//新状态表示j消失;
                    dp[t]=max(dp[s]+p[i][j],dp[t]);
                }
            }
        }
        int ans=0;
        for(int i=0;i<(1<<n);i++){
            ans=max(ans,dp[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}





ZOJ 4257 Most Powerful,布布扣,bubuko.com

ZOJ 4257 Most Powerful

标签:des   style   os   io   for   代码   ar   div   

原文地址:http://blog.csdn.net/kimi_r_17/article/details/38294419

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!