码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2845 Beans

时间:2014-07-30 20:46:54      阅读:262      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   for   ar   

Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
bubuko.com,布布扣


Now, how much qualities can you eat and then get ?
 

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn‘t beyond 1000, and 1<=M*N<=200000.
 

Output
For each case, you just output the MAX qualities you can eat and then get.
 

Sample Input
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6
 

Sample Output
242
 

Source
 
每行来一次最大非连续子列。完了压缩后最后再来一次=。=,不过要符合条件啦
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
using namespace std;
const int maxn=200020;
int n,m;
int sum[maxn],a[maxn];

int main()
{
   int n,m;
   while(~scanf("%d%d",&n,&m))
   {
       for(int i=1;i<=n;i++)
       {
           for(int j=1;j<=m;j++)
             scanf("%d",&a[j]);
           for(int j=2;j<=m;j++)
             a[j]=max(a[j-2]+a[j],a[j-1]);
           sum[i]=a[m];
       }
       for(int i=2;i<=n;i++)
          sum[i]=max(sum[i-2]+sum[i],sum[i-1]);
       printf("%d\n",sum[n]);
   }
   return 0;
}


HDU 2845 Beans,布布扣,bubuko.com

HDU 2845 Beans

标签:des   style   http   color   os   io   for   ar   

原文地址:http://blog.csdn.net/u013582254/article/details/38305855

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!