码迷,mamicode.com
首页 > 其他好文 > 详细

【POJ 2891】Strange Way to Express Integers(扩展欧几里得)

时间:2016-05-06 14:55:10      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:

【POJ 2891】Strange Way to Express Integers(扩展欧几里得)

Time Limit: 1000MS   Memory Limit: 131072K
Total Submissions: 12934   Accepted: 4130

Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1, a2, …, ak. For some non-negative m, divide it by every ai (1 ≤ ik) to find the remainder ri. If a1, a2, …, ak are properly chosen, m can be determined, then the pairs (ai, ri) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers ai, ri (1 ≤ ik).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input

2
8 7
11 9

Sample Output

31

Hint

All integers in the input and the output are non-negative and can be represented by 64-bit integral types.

Source


对于ax ≡ b(mod m) 很熟练的一套扩欧板子拍上去,。

这题有点麻烦,给了n对数ai ri 让求出一个数x 对于n组数都存在mi使 x ≡ ai*mi+ri 找出最小的x 找不出输出-1


首先考虑n = 1的情况 x = a*m+r(m = 1,2,3......)

对于n = 2时,即要求上面的x同时要满足x = a1*m1+r1

从第一个式子得出 x = a0+r0

这样对于第二个式子,其实也就是找一个c满足 x+c*a0 ≡ r1(mod a2)

以此类推,第三个式子,也就是找对于上面求出来的x(实则为x+c*a0) 找一个c满足 x+c*LCM(a0,a1) ≡ r2(mod a2)


这样按顺序递推着用扩欧即可一步步求得最终答案。

需要注意的是LCM(a0,a1) 其实就是a0*a1/gcd(a0,a1) 但是直接乘可能爆 先除再乘 a0/gcd(a0,a1)*a1

其次,每一步求扩欧的过程中其实就能得到gcd

其次次。WA了好久,最后发现对于答案,最重要对LCM(a0,a1,a2,...,an-)取余。。谁让找的是最小值。。。。


代码如下:

1#include <iostream>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <list>
#include <algorithm>
#include <map>
#include <set>
#define LL long long
#define Pr pair<int,int>
#define fread() freopen("in.in","r",stdin)
#define fwrite() freopen("out.out","w",stdout)

using namespace std;
const int INF = 0x3f3f3f3f;
const int msz = 10000;
const int mod = 1e9+7;
const double eps = 1e-8;

LL extend_gcd(LL a,LL b,LL &x,LL &y)
{
	if(a == 0 && b == 0) return -1;
	if(!b)
	{
		x = 1;
		y = 0;
		return a;
	}
	LL d = extend_gcd(b,a%b,y,x);
	y -= a/b*x;
	return d;
}

LL d;
LL gcd(LL a,LL m,LL c)
{
	LL x,y;
	d = extend_gcd(a,m,x,y);
	if(c%d) return -1;
	x = ((x%m)*(c/d))%m;
	return (x%(m/d)+m/d)%(m/d);
}

int main()
{
	//fread();
	//fwrite();

	int n;
	LL a,r;
	while(~scanf("%d",&n))
	{
		LL tmp = 1;
		LL ans = 0;
		LL c;
		bool f = 1;
		scanf("%lld%lld",&a,&r);
		tmp = a;
		ans = a+r;
		n--;
		while(n--)
		{
			scanf("%lld%lld",&a,&r);
			//if(r >= a) f = 0;
			if(!f) continue;
			c = gcd(tmp,a,((r-ans)%a+a)%a);
		//	printf("%lld ans:%lld LCM:%lld mod:%lld =%lld\n",d,ans,tmp,a,((r-ans)%a+a)%a);
			if(c == -1) f = 0;
			ans += tmp*c;
			tmp = tmp/d*a;
			ans %= tmp;
		}
		if(!f) puts("-1");
		else printf("%lld\n",ans);
	}

	return 0;
}




【POJ 2891】Strange Way to Express Integers(扩展欧几里得)

标签:

原文地址:http://blog.csdn.net/challengerrumble/article/details/51326044

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!