码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3252 Round Numbers

时间:2014-07-31 00:08:55      阅读:350      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   strong   io   for   



Time Limit: 2000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

[]   [Go Back]   [Status]  

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone‘ (also known as ‘Rock, Paper, Scissors‘, ‘Ro, Sham, Bo‘, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can‘t even flip a coin because it‘s so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start.. Finish

Sample Input

2 12

Sample Output

6

Source

[]   [Go Back]   [Status]  

bubuko.com,布布扣



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef long long int LL;
int bit[70],bn;

LL C[100][100],g[100];

void init_C()
{
    for(int i=0;i<100;i++)
        C[i][0]=C[i][i]=1LL;
    for(int i=2;i<100;i++)
    {
        for(int j=1;j<i;j++)
            C[i][j]=C[i-1][j]+C[i-1][j-1];
    }
}

void get_bit(LL x)
{
    bn=0;
    if(x==0)
        bit[bn++]=0;
    while(x)
    {
        if(x%2==1)
            bit[bn++]=1LL;
        else bit[bn++]=0LL;
        x/=2LL;
    };
}

LL GAO_x(int x)
{
    int t=x-1;
    LL ret=0;
    for(int i=0;i<=t;i++)
    {
        if(i>=t-i+1)
        {
            ret+=C[t][i];
        }
    }
    return ret;
}

void init()
{
    for(int i=1;i<=100;i++)
        g[i]=GAO_x(i);
}

int n1[1000];

LL calu(LL x)
{

    LL ret=1;
    for(int i=1;i<bn;i++)
        ret+=g[i];
    int one=1,zero=0;
    for(int i=bn-2;i>=0;i--)
    {
        if(bit[i]==0)
        {
            zero++;
            continue;
        }
        else
        {
            int t0=zero+1,t1=one;

            for(int j=0;j<=i;j++)
            {
                if(j+t0>=one+i-j)
                {
                    ret+=C[i][j];
                }
            }

            one++;
        }
    }
    if(zero>=one) ret++;
    return ret;
}

int main()
{
    init_C();init();
    LL x,y;
    while(cin>>x>>y)
    {
        if(y<x) swap(x,y);
        get_bit(y);
        LL part1=calu(y),part2;
        get_bit(x-1);
        if(x-1==0) part2=1;
        else part2=calu(x-1);
        cout<<part1-part2<<endl;
    }
}



POJ 3252 Round Numbers,布布扣,bubuko.com

POJ 3252 Round Numbers

标签:des   style   http   color   os   strong   io   for   

原文地址:http://blog.csdn.net/ck_boss/article/details/38306899

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!