码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2647 Reward(图论-拓扑排序)

时间:2014-07-31 17:09:57      阅读:218      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   for   ar   

Reward



Problem Description
Dandelion‘s uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a‘s reward should more than b‘s.Dandelion‘s unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work‘s reward will be at least 888 , because it‘s a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a‘s reward should be more than b‘s.
 

Output
For every case ,print the least money dandelion ‘s uncle needs to distribute .If it‘s impossible to fulfill all the works‘ demands ,print -1.
 

Sample Input
2 1 1 2 2 2 1 2 2 1
 

Sample Output
1777 -1
 

Author
dandelion
 

Source
 

Recommend
yifenfei   |   We have carefully selected several similar problems for you:  1285 3342 1811 2680 2112 
 


题目大意:

n个人,m条边,每条边a,b 表示a比b的工资多1,每个人的工资至少888,问你工资和至少多少?如果出现矛盾关系,输出-1


解题思路:

根据人的工资关系建立拓扑图,工资尽量从888开始,然后根据是否能全部排好序判断是出现矛盾关系。


解题思路:

#include <iostream>
#include <cstdio>
#include <queue>
#include <vector>
using namespace std;

const int maxn=11000;
int n,m,ans[maxn],r[maxn];
vector <vector<int> > v;

void input(){
    v.clear();
    v.resize(n+1);
    for(int i=0;i<=n;i++){
        ans[i]=-1;
        r[i]=0;
    }
    int a,b;
    while(m-- >0){
        scanf("%d%d",&a,&b);
        v[b].push_back(a);
        r[a]++;
    }
}

void solve(){
    queue <int> q;
    for(int i=1;i<=n;i++){
        if(r[i]==0) q.push(i);
    }
    int tmp=888;
    while(!q.empty()){
        int qsize=q.size();
        while(qsize-- >0){
            int s=q.front();
            q.pop();
            ans[s]=tmp;
            for(int i=0;i<v[s].size();i++){
                int d=v[s][i];
                r[d]--;
                if(r[d]==0) q.push(d);
            }
        }
        tmp++;
    }
    int sum=0;
    for(int i=1;i<=n;i++){
        if(ans[i]>0) sum+=ans[i];
        else{
            sum=-1;
            break;
        }
    }
    printf("%d\n",sum);
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        input();
        solve();
    }
    return 0;
}





HDU 2647 Reward(图论-拓扑排序),布布扣,bubuko.com

HDU 2647 Reward(图论-拓扑排序)

标签:des   style   http   color   os   io   for   ar   

原文地址:http://blog.csdn.net/a1061747415/article/details/38317031

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!