码迷,mamicode.com
首页 > 其他好文 > 详细

不可摸数(杭电1999)

时间:2014-07-31 21:02:27      阅读:216      评论:0      收藏:0      [点我收藏+]

标签:des   io   数据   for   amp   ef   return   c   

/*不可摸数
Problem Description
s(n)是正整数n的真因子之和,即小于n且整除n的因子和.例如s(12)=1+2+3+4+6=16.如果任何
数m,s(m)都不等于n,则称n为不可摸数.

 

Input
包含多组数据,首先输入T,表示有T组数据.每组数据1行给出n(2<=n<=1000)是整数。
 

Output
如果n是不可摸数,输出yes,否则输出no
 

Sample Input
3
2
5
8
 

Sample Output
yes
yes
no

*/
/*用打表法将 n的真因子和存到a[n]中。
注意打表的上限 确定M>=500000;
*/
#include<stdio.h>
#define M 500010
__int64 a[M];
int sum[1010];
void asd()
{
    int N;
    N=M/2;
    int i,j;
    for(i=1;i<N;i++)
            for(j=2*i;j<M;j+=i)
            a[j]+=i;
    for(i=0;i<M;i++)
    {
        if(a[i]<=1000)
       sum[a[i]]=1;
    }
}
int main()
{
    int test,i;
    scanf("%d",&test);
    asd();
    while(test--)
    {
        int t;
        scanf("%d",&t);
        if(sum[t])
        printf("no\n");
        else
        printf("yes\n");
    }
    return 0;
}

不可摸数(杭电1999),布布扣,bubuko.com

不可摸数(杭电1999)

标签:des   io   数据   for   amp   ef   return   c   

原文地址:http://blog.csdn.net/hdd871532887/article/details/38320657

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!