码迷,mamicode.com
首页 > 其他好文 > 详细

poj2352

时间:2014-08-01 12:58:21      阅读:214      评论:0      收藏:0      [点我收藏+]

标签:des   http   java   使用   os   strong   io   数据   

Stars

Time Limit: 1000 MS Memory Limit: 65536 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
bubuko.com,布布扣

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

Ural Collegiate Programming Contest 1999
 
解析:
          
   
由于题目的输入已经是按照Y的升序,(如果Y相同,就按照X升序排列), 因此可以做到每录入一个数据,就计算出它的level同时update,用c为每个坐标为X的数据做记录(利用树状数组组织)。
Level统计的时候,利用树状数组,在o(logn)时间内完成
PS(千万不要使用c++的cin,cout,因为会产生超时的现象,毕竟它们比scanf,printf速度慢。TLE就不好了。
#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
using namespace std;
#define N 32005
int c[N],result[N],n;
int lowbit(int x)
{
    return x&(-x);
}
void add(int i,int v)
{
    while(i<N)
    {
        c[i]+=v;
        i+=lowbit(i);
    }
}
int getsum(int i)
{
    int sum=0;
    while(i>0)
    {
        sum+=c[i];
        i-=lowbit(i);
    }
    return sum;
}
int main()
{
    int n;
    scanf("%d",&n);
    int i,x,y;
    memset(c,0,sizeof(c));
    memset(result,0,sizeof(result));
    for(i=0; i<n; i++)
    {
        scanf("%d%d",&x,&y);
        x++;
        result[getsum(x)]++;
        add(x,1);
    }
    for(i=0; i<n; i++)
    {
        printf("%d\n",result[i]);
    }
    return 0;
}

poj2352,布布扣,bubuko.com

poj2352

标签:des   http   java   使用   os   strong   io   数据   

原文地址:http://www.cnblogs.com/famousli/p/3884361.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!