码迷,mamicode.com
首页 > 其他好文 > 详细

(算法竞赛入门经典 优先队列)LA 3135(前K条指令)

时间:2014-08-01 13:47:14      阅读:235      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   io   for   2014   art   

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.

Query-1: ?Every five minutes, retrieve the maximum temperature over the past five minutes.? Query-2: ?Return the average temperature measured on each floor over the past 10 minutes.?

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

For the Argus, we use the following instruction to register a query:

Register Q_num Period

Q_num (0 < Q_num ≤ 3000) is query ID-number, and Period (0 < Period ≤ 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.

Input 

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of ?#?.

The second part is your task. This part contains only one line, which is one positive integer K (≤ 10000).

Output 

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200
Register 2005 300
#
5


Sample output
2004
2005
2004
2004
2005


代码如下:

/*
 * LA_3135.cpp
 *
 *  Created on: 2014年8月1日
 *      Author: pc
 */



#include <iostream>
#include <cstdio>
#include <queue>

using namespace std;


struct Item{
	int num;//指令的序号
	int period;//指令的执行周期
	int time;//指令的下一次执行时间

	bool operator<(const Item& b)const{
		if(time != b.time){
			return time > b.time;
		}

		return num > b.num;
	}
};


int main(){
	char s[20];

	priority_queue<Item> pq;
	while(scanf("%s",&s),s[0] != ‘#‘){
		Item item;
		scanf("%d%d",&item.num,&item.period);
		item.time = item.period;
		pq.push(item);
	}

	int k;
	scanf("%d",&k);
	while(k--){//核心逻辑
		Item r = pq.top();//不断的取出来然后不断的插进去
		pq.pop();

		printf("%d\n",r.num);
		r.time += r.period;

		pq.push(r);
	}


	return 0;
}



(算法竞赛入门经典 优先队列)LA 3135(前K条指令),布布扣,bubuko.com

(算法竞赛入门经典 优先队列)LA 3135(前K条指令)

标签:des   style   color   os   io   for   2014   art   

原文地址:http://blog.csdn.net/hjd_love_zzt/article/details/38333443

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!