码迷,mamicode.com
首页 > 其他好文 > 详细

zju 1295 Reverse Text

时间:2014-08-01 19:23:32      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:style   blog   http   color   os   strong   io   for   

Reverse Text

Time Limit: 2 Seconds      Memory Limit: 65536 KB

In most languages, text is written from left to right. However, there are other languages where text is read and written from right to left. As a first step towards a program that automatically translates from a left-to-right language into a right-to-left language and back, you are to write a program that changes the direction of a given text.


Input Specification

The input contains several test cases. The first line contains an integer specifying the number of test cases. Each test case consists of a single line of text which contains at most 70 characters. However, the newline character at the end of each line is not considered to be part of the line.


Output Specification

For each test case, print a line containing the characters of the input line in reverse order.


Sample Input

3
Frankly, I don‘t think we‘ll make much
money out of this scheme.
madam I‘m adam


Sample Output

hcum ekam ll‘ew kniht t‘nod I ,ylknarF
.emehcs siht fo tuo yenom
mada m‘I madam

 

 

bubuko.com,布布扣
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
    int n;
    n=0;
    string s;
    char ss[80];
    while(cin.getline(ss,80))
    {
        if(n==0) n=1;
        else
            {
             s=ss;
            reverse(s.begin(),s.end());
        cout<<s<<endl;
        }
      
        
    }
    return 0;
}
View Code

 

 

 

 

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
    int n;
    n=0;
    string s;
    char ss[80];
    while(cin.getline(ss,80))
    {
     if(n==0) n=1;
     else
   {
       s=ss;
      reverse(s.begin(),s.end());
        cout<<s<<endl;
     }
     
       
    }
    return 0;
}


 

zju 1295 Reverse Text,布布扣,bubuko.com

zju 1295 Reverse Text

标签:style   blog   http   color   os   strong   io   for   

原文地址:http://www.cnblogs.com/2014acm/p/3885526.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!