码迷,mamicode.com
首页 > 其他好文 > 详细

zju 1241 Geometry Made Simple

时间:2014-08-01 19:27:32      阅读:308      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   strong   io   

Geometry Made Simple

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Mathematics can be so easy when you have a computer. Consider the following example. You probably know that in a right-angled triangle, the length of the three sides a, b, c (where c is the longest side, called the hypotenuse) satisfy the relation a*a+b*b=c*c. This is called Pythagora‘s Law.

Here we consider the problem of computing the length of the third side, if two are given.

bubuko.com,布布扣

Input

The input contains the descriptions of several triangles. Each description consists of a line containing three integers a, b and c, giving the lengths of the respective sides of a right-angled triangle. Exactly one of the three numbers is equal to -1 (the ‘unknown‘ side), the others are positive (the ‘given‘ sides).

A description having a=b=c=0 terminates the input.


Output

For each triangle description in the input, first output the number of the triangle, as shown in the sample output. Then print "Impossible." if there is no right-angled triangle, that has the ‘given‘ side lengths. Otherwise output the length of the ‘unknown‘ side in the format "s = l", where s is the name of the unknown side (a, b or c), and l is its length. l must be printed exact to three digits to the right of the decimal point.

Print a blank line after each test case.


Sample Input

3 4 -1
-1 2 7
5 -1 3
0 0 0


Sample Output

Triangle #1
c = 5.000

Triangle #2
a = 6.708

Triangle #3
Impossible.

 

 

bubuko.com,布布扣
#include <iostream>
#include<cmath>
using namespace std;
int main(int argc, char *argv[])
{
    int a,b,c,n;
    n=0;
    cout.precision(3);
    while(cin>>a>>b>>c)
    {     
           n++;
        if(a==0&& b==0 && c==0)    break;
            if(a==-1)
            {
                if(c*c-b*b<=0) 
                {
                cout<<"Triangle #"    <<n <<endl;
                    cout<<"Impossible."    <<endl;
                    cout<<endl;
                }
                
                else
                    {
                    cout<<"Triangle #"    <<n <<endl;
                    cout<<"a = " <<fixed<<pow(c*c-b*b,.5)    <<endl;
                    cout<<endl;    
                    
                }
            }
            
    else    if(b==-1)
            {
                if(c*c-a*a<=0) 
                {
                cout<<"Triangle #"    <<n <<endl;
                    cout<<"Impossible."    <<endl;
                    cout<<endl;
                }
                
                else
                    {
                    cout<<"Triangle #"    <<n <<endl;
                    cout<<"b = " <<fixed<<pow(c*c-a*a,.5)    <<endl;
                    cout<<endl;    
                    
                }
            }    
            
            
    else    if(c==-1)
            {
                      cout<<"Triangle #"    <<n <<endl;  
                    cout<<"c = " <<fixed<<pow(a*a+b*b,.5)    <<endl;
                    cout<<endl;    
                    
                }
                
            
                
                
            
            
    }

    return 0;
}
View Code

 

#include <iostream>
#include<cmath>
using namespace std;
int main(int argc, char *argv[])
{
 int a,b,c,n;
 n=0;
 cout.precision(3);
 while(cin>>a>>b>>c)
 {    
        n++;
     if(a==0&& b==0 && c==0)    break;
   if(a==-1)
   {
    if(c*c-b*b<=0)
    {
    cout<<"Triangle #" <<n <<endl;
     cout<<"Impossible." <<endl;
     cout<<endl;
    }
    
    else
     {
     cout<<"Triangle #" <<n <<endl;
     cout<<"a = " <<fixed<<pow(c*c-b*b,.5) <<endl;
     cout<<endl; 
     
    }
   }
   
 else if(b==-1)
   {
    if(c*c-a*a<=0)
    {
    cout<<"Triangle #" <<n <<endl;
     cout<<"Impossible." <<endl;
     cout<<endl;
    }
    
    else
     {
     cout<<"Triangle #" <<n <<endl;
     cout<<"b = " <<fixed<<pow(c*c-a*a,.5) <<endl;
     cout<<endl; 
     
    }
   } 
   
   
 else if(c==-1)
   {
             cout<<"Triangle #" <<n <<endl; 
     cout<<"c = " <<fixed<<pow(a*a+b*b,.5) <<endl;
     cout<<endl; 
     
    }
    
   
    
    
   
   
 }

 return 0;
}

zju 1241 Geometry Made Simple,布布扣,bubuko.com

zju 1241 Geometry Made Simple

标签:des   style   blog   http   color   os   strong   io   

原文地址:http://www.cnblogs.com/2014acm/p/3885517.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!