码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2777 线段树的区间更新

时间:2014-08-01 22:35:22      阅读:290      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   java   os   strong   

Count Color

Time Limit: 1000 MS Memory Limit: 65536 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status] [Discuss]

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C.
2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1


#include <iostream>
#include <string.h>
#include <stdio.h>

using namespace std;
bool many[32];

struct node
{
    int l;
    int r;
    int col;
} tr[100000*4];

void build(int root,int l,int r)
{
    tr[root].l=l;
    tr[root].r=r;
    int mid=(l+r)/2;
    if(l!=r)
    {
        build(root*2,l,mid);
        build(root*2+1,mid+1,r);
    }
}

void insert(int root,int l,int r,int c)
{
    int mid=(tr[root].l+tr[root].r)/2;
    if(l==tr[root].l && r==tr[root].r)
    {
        tr[root].col=c;
        return ;
    }
    if(tr[root].col)     ///延迟覆盖
    {
        tr[2*root].col=tr[root].col;
        tr[2*root+1].col=tr[root].col;
        tr[root].col=0;
    }

    if(r<=mid)
    {
        insert(2*root,l,r,c);
        return ;
    }
    if(l>mid)
    {
        insert(2*root+1,l,r,c);
        return ;
    }
    insert(2*root,l,mid,c);
    insert(2*root+1,mid+1,r,c);
}

int calu(int root,int l,int r)
{
    int sum = 0;
    if(tr[root].col){
        if(many[tr[root].col]==false){
            sum++;
            many[tr[root].col]=true;
        }
        return  sum;
    }
    int mid=(tr[root].l+tr[root].r)/2;
    if(r<=mid)
        sum += calu(root*2,l,r);
    else if(l>mid)
        sum += calu(root*2+1,l,r);
    else{
        sum += calu(root*2,l,mid);
        sum += calu(root*2+1,mid+1,r);
    }
    return  sum;
}
int main()
{
    int x,y,z;
    int n,t,o;
    char op;
    while(scanf("%d%d%d",&n,&t,&o)!=EOF)
    {
        tr[1].col=1;
        build(1,1,n);
        while(o--)
        {
            getchar();
            scanf("%c",&op);
            if(op==C)
            {
                scanf("%d%d%d",&x,&y,&z);
                if(x>y)  swap(x,y);
                insert(1,x,y,z);
            }
            else
            {
                scanf("%d%d",&x,&y);
                if(x>y)  swap(x,y);
                memset(many,false,sizeof(many));
                printf("%d\n",calu(1,x,y));
            }
        }
    }
    return 0;
}

 

poj 2777 线段树的区间更新,布布扣,bubuko.com

poj 2777 线段树的区间更新

标签:des   style   blog   http   color   java   os   strong   

原文地址:http://www.cnblogs.com/zhangying/p/3885651.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!