码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1845 Jimmy’s Assignment (二分图)

时间:2014-08-01 23:16:42      阅读:220      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   java   os   strong   

Jimmy’s Assignment

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 896    Accepted Submission(s): 379


Problem Description
Jimmy is studying Advanced Graph Algorithms at his university. His most recent assignment is to find a maximum matching in a special kind of graph. This graph is undirected, has N vertices and each vertex has degree 3. Furthermore, the graph is 2-edge-connected (that is, at least 2 edges need to be removed in order to make the graph disconnected). A matching is a subset of the graph’s edges, such that no two edges in the subset have a common vertex. A maximum matching is a matching having the maximum cardinality.
  Given a series of instances of the special graph mentioned above, find the cardinality of a maximum matching for each instance.
 

Input
The first line of input contains an integer number T, representing the number of graph descriptions to follow. Each description contains on the first line an even integer number N (4<=N<=5000), representing the number of vertices. Each of the next 3*N/2 lines contains two integers A and B, separated by one blank, denoting that there is an edge between vertex A and vertex B. The vertices are numbered from 1 to N. No edge may appear twice in the input.
 

Output
For each of the T graphs, in the order given in the input, print one line containing the cardinality of a maximum matching.
 

Sample Input
2 4 1 2 1 3 1 4 2 3 2 4 3 4 4 1 2 1 3 1 4 2 3 2 4 3 4
 

Sample Output
2 2


这题真的很坑!!937ms过的,期间有的代码好像搞错了,竟然速度只400+ms.其实答案就是n/2。

主要是bool数组真的很省时间!!


#include"stdio.h"
#include"string.h"
#include"queue"
#include"vector"
using namespace std;
#define N 5005
#define M 30005
int lx[N],ly[N];
bool mark[N];
vector<int>g[N];
int find(int k)
{
    int i,v;
    for(i=0;i<g[k].size();i++)
    {
        v=g[k][i];
        if(!mark[v])
        {
            mark[v]=1;
            if(ly[v]==-1||find(ly[v]))
            {
                ly[v]=k;lx[k]=v;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int i,u,v,n,T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(i=0;i<=n;i++)
            g[i].clear();
        for(i=0;i<n*3/2;i++)
        {
            scanf("%d%d",&u,&v);
            g[u].push_back(v);
            g[v].push_back(u);
        }
        memset(lx,-1,sizeof(lx));
        memset(ly,-1,sizeof(ly));
        int ans=0;
        for(i=1;i<=n;i++)
        {
            if(lx[i]!=-1)
                continue;
            //memset(mark,0,(n+2)*sizeof(int));
            memset(mark,0,sizeof(mark));
            ans+=find(i);
        }
        printf("%d\n",ans/2);
    }
    return 0;
}



hdu 1845 Jimmy’s Assignment (二分图),布布扣,bubuko.com

hdu 1845 Jimmy’s Assignment (二分图)

标签:des   style   blog   http   color   java   os   strong   

原文地址:http://blog.csdn.net/u011721440/article/details/38341599

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!