码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2647 Reward(图论-拓扑排序)

时间:2014-08-03 18:03:26      阅读:224      评论:0      收藏:0      [点我收藏+]

标签:图论   拓扑排序   

Reward


Problem Description
Dandelion‘s uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a‘s reward should more than b‘s.Dandelion‘s unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work‘s reward will be at least 888 , because it‘s a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a‘s reward should be more than b‘s.
 

Output
For every case ,print the least money dandelion ‘s uncle needs to distribute .If it‘s impossible to fulfill all the works‘ demands ,print -1.
 

Sample Input
2 1 1 2 2 2 1 2 2 1
 

Sample Output
1777 -1
 

Author
dandelion
 

Source
 

Recommend
yifenfei


题目大意:

n个人,m条边,每条边a,b 表示a比b的工资要多,每个人的工资至少888,问满足关系的工资总和至少多少?如果出现关系矛盾,输出-1


解题思路:

根据工资关系建立拓扑图,0入度的人工资从888开始,一层一层,逐渐增加工资,若最后还有人入度不为0,则出现矛盾。


参考代码:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <queue>
using namespace std;

const int MAXN = 10010;
int inDegree[MAXN], ans, cnt, n, m;
vector<int> child[MAXN];

struct State {
    int reward, node;
    State(int _reward, int _node) : reward(_reward), node(_node) {}
};
queue<State> q;

void init() {
    memset(inDegree, 0, sizeof(inDegree));
    for (int i = 0; i <= n; i++) {
        child[i].clear();
    }
    ans = cnt = 0;
    while (!q.empty()) q.pop();
}

void input() {
    for (int i = 0; i < m; i++) {
        int a, b;
        cin >> a >> b;
        inDegree[a]++;
        child[b].push_back(a);
    }
}

void work() {
    for (int i = 1; i <= n; i++) {
        if (inDegree[i] == 0) {
            q.push(State(888, i));
            cnt++;
        }
    }
    while (!q.empty()) {
        State cur = q.front();
        q.pop();

        ans += cur.reward;

        for (int i = 0; i < child[cur.node].size(); i++) {
            inDegree[child[cur.node][i]]--;
            if (inDegree[child[cur.node][i]] == 0) {
                q.push(State(cur.reward+1, child[cur.node][i]));
                cnt++;
            }
        }
    }
}

void output() {
    if (cnt == n) {
        cout << ans << endl;
    } else {
        cout << -1 << endl;
    }
}

int main() {
    ios::sync_with_stdio(false);
    while (cin >> n >> m) {
        init();
        input();
        work();
        output();
    }
    return 0;
}


HDU 2647 Reward(图论-拓扑排序),布布扣,bubuko.com

HDU 2647 Reward(图论-拓扑排序)

标签:图论   拓扑排序   

原文地址:http://blog.csdn.net/wujysh/article/details/38359153

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!