码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4006 The kth great number (基本算法-水题)

时间:2014-08-03 23:19:36      阅读:287      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   for   

The kth great number


Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
 

Output
The output consists of one integer representing the largest number of islands that all lie on one line. 
 

Sample Input
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
 

Sample Output
1 2 3
Hint
Xiao Ming won‘t ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
 

Source
 

Recommend
lcy
 


题目大意:

有m组操作,求第K大数。I为insert操作,即插入1个数,Q为询问,输出此时的第K大数。


解题思路:

一道水题让我智商捉鸡了,居然笨到想去用线段树去做。后来发现1个set搞定,就存K个大数,超过的把小的踢掉,输出第一个即可。


解题代码:

#include <iostream>
#include <cstdio>
#include <set>
#include <algorithm>
using namespace std;

int n,k;
multiset <long long> mys;

void solve(){
    mys.clear();
    char ch;
    int x;
    for(int i=0;i<n;i++){
        scanf("\n");
        scanf("%c",&ch);
        if(ch=='I'){
            scanf("%lld",&x);
            mys.insert(x);
            if(mys.size()>k) mys.erase(mys.begin());
        }else{
            cout<<*mys.begin()<<endl;
        }
    }
}

int main(){
    while(scanf("%d%d",&n,&k)!=EOF){
        solve();
    }
    return 0;
}




HDU 4006 The kth great number (基本算法-水题),布布扣,bubuko.com

HDU 4006 The kth great number (基本算法-水题)

标签:des   style   blog   http   color   os   io   for   

原文地址:http://blog.csdn.net/a1061747415/article/details/38361795

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!