码迷,mamicode.com
首页 > 其他好文 > 详细

sicily 1194 Message Flood (STL的map和set应用练习)

时间:2014-08-04 18:01:50      阅读:286      评论:0      收藏:0      [点我收藏+]

标签:acm   c语言   编程   stl   

题目:

D - Message Flood
Time Limit:1500MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Well, how do you feel about mobile phone? Your answer would probably be something like that "It‘s so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year‘s Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What‘s worse, Merlin has another long name list of senders that have sent message to him, and he doesn‘t want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin‘s friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that‘s why some message senders are even not included in his friend list.

Input

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin‘s friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

Output

For each case, print one integer in one line which indicates the number of left friends he must send.

Sample Input

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0

Sample Output

3

STL真心方便啊。这题分别用了map和set做了一下。注意这个题有个坑点,就是不区分大小写。。。。。

map代码:

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <stdlib.h>
#include <math.h>
#include <ctype.h>
#include <queue>
#include <map>
#include<algorithm>

using namespace std;
int main()
{
    map<string,int>mp;
    map<string,int>::iterator iter;
    int n, m, i, len, j;
    char s[30];
    while(scanf("%d",&n)!=EOF&&n)
    {
        scanf("%d",&m);
        getchar();
        mp.clear();//如果在外面定义的话要注意清空。
        for(i=0;i<n;i++)
        {
            gets(s);
            len=strlen(s);
            for(j=0;j<len;j++)
            {
                s[j]=tolower(s[j]);//tolower函数的意义是将大写字母全换成小写字母
            }
            mp[s]++;
        }
        for(i=0;i<m;i++)
        {
            gets(s);
            len=strlen(s);
            for(j=0;j<len;j++)
            {
                s[j]=tolower(s[j]);
            }
            mp.erase(s);//erase函数的意义是在该容器中删除该元素
        }
        printf("%d\n",mp.size());//直接用size函数输出容器内元素的个数,不用遍历计数。
    }
    return 0;
}

set代码:

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <stdlib.h>
#include <math.h>
#include <ctype.h>
#include <queue>
#include <map>
#include <set>
#include<algorithm>

using namespace std;
int main()
{
    int n, m, i, len, j;
    char s[30];
    while(scanf("%d",&n)!=EOF&&n)
    {
        scanf("%d",&m);
        getchar();
        set<string>mp;//声明set容器
        set<string>::iterator iter;//声明set迭代器
        for(i=0; i<n; i++)
        {
            gets(s);
            len=strlen(s);
            for(j=0; j<len; j++)
            {
                s[j]=tolower(s[j]);
            }
            mp.insert(s);//向set里加入一个元素
        }
        for(i=0; i<m; i++)
        {
            gets(s);
            len=strlen(s);
            for(j=0; j<len; j++)
            {
                s[j]=tolower(s[j]);
            }
            if(mp.count(s))//判断容器里是否存在该元素
                mp.erase(s);//如果容器里存在该元素,则删除
        }
        printf("%d\n",mp.size());//直接输出容器剩余元素个数。
    }
    return 0;
}


sicily 1194 Message Flood (STL的map和set应用练习),布布扣,bubuko.com

sicily 1194 Message Flood (STL的map和set应用练习)

标签:acm   c语言   编程   stl   

原文地址:http://blog.csdn.net/scf0920/article/details/38369405

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!