码迷,mamicode.com
首页 > 其他好文 > 详细

POJ - 1995 Raising Modulo Numbers

时间:2014-08-05 11:18:39      阅读:245      评论:0      收藏:0      [点我收藏+]

标签:des   style   os   io   for   ar   div   line   

Description

People are different. Some secretly read magazines full of interesting girls‘ pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions Ai Bi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players‘ experience it is possible to increase the difficulty by choosing higher numbers.

You should write a program that calculates the result and is able to find out who won the game.

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression

(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output

2
13195
13

题意:求和

思路:快速幂取模,递归和非递归两个版本

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
typedef long long ll;
using namespace std;

/*int pow_mod(int a, int n, int m) {  
	if (n == 0)  
		return 1;  
	if (n == 1)  
		return a%m;  
	int x = pow_mod(a, n/2, m);  
	ll ans = (ll) x*x%m;  
	if (n % 2 == 1)  
		ans = ans * a % m;  
	return (int)ans;  
}  
*/

int pow_mod(int a, int n, int m)  {
	ll ans = 1;
	ll tmp = (ll)a;
	while (n) {
		if (n & 1)
			ans = (ans * tmp) % m;
		tmp = (tmp * tmp) % m;
		n >>= 1;
	}
	return (int) ans;
}

int main() {
	int t, n, m;
	while (scanf("%d", &t) != EOF && t) {
		for (int i = 0; i < t; i++) {
			int sum = 0;
			scanf("%d%d", &n, &m);
			int a, b;
			for (int j = 0; j < m; j++) {
				scanf("%d%d", &a, &b);
				sum = (sum + pow_mod(a, b, n)) % n;
			}
			printf("%d\n", sum);
		}
	}
	return 0;
}



POJ - 1995 Raising Modulo Numbers,布布扣,bubuko.com

POJ - 1995 Raising Modulo Numbers

标签:des   style   os   io   for   ar   div   line   

原文地址:http://blog.csdn.net/u011345136/article/details/38380283

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!