码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3320(尺取法)

时间:2016-07-07 19:07:19      阅读:283      评论:0      收藏:0      [点我收藏+]

标签:

Jessica‘s Reading Problem
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10076   Accepted: 3356

Description

Jessica‘s a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica‘s text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica‘s text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2

题意:

技术分享

题解:尺取法基础题,啥是尺取法戳这里:http://blog.chinaunix.net/uid-24922718-id-4848418.html

利用map映射每个知识点,每次左右推进就好了。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <map>
using namespace std;
typedef long long LL;
const int N = 1000005;
int a[N];
map<int,int> mp;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        mp.clear();
        int m=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            if(mp[a[i]]==0) m++;
            mp[a[i]]=1;
        }
        mp.clear();
        int l=1,r=1,cnt=0,ans=n+1;
        while(l<=n){
            while(r<=n&&cnt<m){
                if(mp[a[r]]==0) cnt++;
                mp[a[r]]++;
                r++;
            }
            if(cnt<m) break;
            if(cnt==m) ans = min(ans,r-l);
            mp[a[l]]--;
            if(mp[a[l]]==0) cnt--;
            l++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

poj 3320(尺取法)

标签:

原文地址:http://www.cnblogs.com/liyinggang/p/5650840.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!