码迷,mamicode.com
首页 > 其他好文 > 详细

lightOJ1370 欧拉函数性质

时间:2016-07-16 21:01:07      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:

D - (例题)欧拉函数性质

Crawling in process... Crawling failed Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Submit Status

Description

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo‘s length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题目大意:这道题本质上的意思就是给你一个数N,让你寻找最小的k满足&(k)>=N(&指的是欧拉函数)

思路分析:考察了欧拉函数的简单性质,即满足&(k)>=N的最小数为N+1Z之后的第一个素数

代码:

技术分享
#include<iostream>
#include<cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long ll;
const int maxn=1e6+100;
int phi[maxn];
int prime[maxn];
bool check[maxn];
int tot;
void make_phi()
{
    tot=0;
    memset(check,true,sizeof(check));
    phi[1]=1;
    for(int i=2;i<=maxn;i++)
    {
        if(check[i])
        {
            prime[tot++]=i;
            phi[i]=i-1;
        }
        for(int j=0;j<tot&&i*prime[j]<=maxn;j++)
        {
            check[i*prime[j]]=false;
            if(i%prime[j]==0)
            {
                phi[i*prime[j]]=phi[i]*prime[j];
                break;
            }
            else prime[i*prime[j]]=phi[i]*(prime[j]-1);
        }
    }
}
int kase;
int main()
{
    int T;
     make_phi();
    scanf("%d",&T);
    kase=0;
    ll num;
    while(T--)
    {
        int n;
        scanf("%d",&n);
        ll ans=0;
        while(n--)
        {
            scanf("%lld",&num);
            ll k=num+1;
            for(ll i=k;;i++)
            {
                if(check[i])
                {
                    ans+=i;
                    break;
                }
            }
        }
        printf("Case %d: %lld Xukha\n",++kase,ans);
    }
}
View Code

 

lightOJ1370 欧拉函数性质

标签:

原文地址:http://www.cnblogs.com/xuejianye/p/5676713.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!