码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5720 Wool BestCoder 2nd Anniversary (区间覆盖)

时间:2016-07-19 10:00:32      阅读:274      评论:0      收藏:0      [点我收藏+]

标签:

Wool

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 686    Accepted Submission(s): 192

Problem Description
At dawn, Venus sets a second task for Psyche.
She is to cross a river and fetch golden wool from violent sheep who graze on the other side.
The sheep are wild and tameless, so Psyche keeps on throwing sticks to keep them away.
There are n技术分享 sticks on the ground, the length of the i技术分享-th stick is a技术分享i技术分享技术分享.
If the new stick she throws forms a triangle with any two sticks on the ground, the sheep will be irritated and attack her.
Psyche wants to throw a new stick whose length is within the interval [L,R]技术分享. Help her calculate the number of valid sticks she can throw next time.

Input
The first line of input contains an integer T技术分享 (1T10)技术分享, which denotes the number of test cases.
For each test case, the first line of input contains single integer n,L,R技术分享 (2n10技术分享5技术分享,1LR10技术分享18技术分享)技术分享.
The second line contains n技术分享 integers, the i技术分享-th integer denotes a技术分享i技术分享技术分享 (1a技术分享i技术分享10技术分享18技术分享)技术分享.
Output
For each test case, print the number of ways to throw a stick.

Sample Input
2 2 1 3 1 1 4 3 10 1 1 2 4
Sample Output
2 5
Hint
In the first example, $ 2, 3 $ are available. In the second example, $ 6, 7, 8, 9, 10 $ are available.
Source
Recommend
wange2014   |   We have carefully selected several similar problems for you:  5722 5721 5717 5716 5715 
 
题意:我做这道题时WA了很多发,发现是想太多了。

给你n个数和L,R。问你在【L,R】的区间内有多少个数不能和a数组中的任意两个数构成三角形。


题解:首先给n个数sort一下,你会发现,在这n个数中,最不能取的且最大的数就是a[n](n从1开始)。对于i:1~n-1中,最不能取的区间就是【a[i+1]-a[i]+1,a[i+1]+a[i]-1】,枚举这个区间的i:1~n-1,再和【L,R】相比,取其相对于【L,R】的补集即可。

AC代码:
#include<stdio.h>
#include<iostream>
#include<algorithm>
typedef long long LL;
typedef unsigned long long uLL;
const int N=100010;
LL a[N]; 
int main()
{
	int n,t;
	LL R ,L;
	LL ans;
	scanf("%d",&t);
	while(t--)
	{
		ans=0;
		scanf("%d%I64d%I64d",&n,&L,&R);
		for(LL i=1;i<=n;i++)
		scanf("%I64d",&a[i]);
		std::sort(a,a+n+1);
		/*
		LL res=a[n]+a[n-1];
		LL sd=std::max(L,res);
		ans=R-sd+1;
		*/
		LL l,r;
		for(LL i=n-1;i>=1;--i)
		{    
		   
			 l=a[i+1]-a[i]+1; 
			 r=a[i+1]+a[i]-1;
			if(l>R||r<L)continue;
			if(R>r) ans+=R-r;
			R=l-1;
			if(L>R)break; 
		}
		if(L<=R) ans+=R-L+1;
		
		printf("%I64d\n",ans); 
	
	}
}


HDU 5720 Wool BestCoder 2nd Anniversary (区间覆盖)

标签:

原文地址:http://blog.csdn.net/liangzhaoyang1/article/details/51945069

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!