码迷,mamicode.com
首页 > 其他好文 > 详细

D - Babelfish

时间:2014-08-08 12:47:45      阅读:296      评论:0      收藏:0      [点我收藏+]

标签:二分查找   poj2503   

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.


题目大意:

给出每两个字符串,它们代表相同意思的不同语言,给出一种语言的意思,将其转换成另一种语言,如果没有找到,输出“eh”。

解题思路:本题最好采用字典树,估计用时较少,我采用的是二分查找,用时700ms。

代码如下:C/C++代码

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct node
{
    char s1[20],s2[20];
} a[100005];
int cmp(node a,node b)
{
    return strcmp(a.s2,b.s2)<0;
}
int main()
{
    int i,j,low,mid,high,flag=1,len = 0;
    char s[50];
    while(gets(s))
    {
        if(strlen(s)==0)
        break;
        sscanf(s,"%s%s",a[len].s1,a[len].s2);
        len++;
    }
    sort(a,a+len,cmp);//按字典序排序
    //二分查找
    while(gets(s))
    {
        low=0;
        high=len-1;
        flag=1;
        while(low<=high)
        {
            int mid =(low+high)>>1;
            if(strcmp(s,a[mid].s2)==0)
            {
                printf("%s\n",a[mid].s1);
                flag = 0;
                break;
            }
            else if(strcmp(s,a[mid].s2)>0)
                low=mid+1;
            else
                high=mid-1;
        }
        if(flag)
            printf("eh\n");
    }
    return 0;
}






D - Babelfish,布布扣,bubuko.com

D - Babelfish

标签:二分查找   poj2503   

原文地址:http://blog.csdn.net/yanghuaqings/article/details/38435981

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!