码迷,mamicode.com
首页 > 其他好文 > 详细

Number Sequence(杭电1005)

时间:2014-08-08 21:29:16      阅读:386      评论:0      收藏:0      [点我收藏+]

标签:des   os   io   for   ar   line   amp   ef   

 

/*Number Sequence
Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

Output
For each test case, print the value of f(n) on a single line.

 

Sample Input
1 1 3
1 2 10
0 0 0
 

Sample Output
2
5

*/
//周期是48,不太明白,记住就行- -
#include<stdio.h>
int str[100000010]={0,1,2,0};
int main()
{
    int a,b,n,i;
    while(~scanf("%d%d%d",&a,&b,&n)&&(a||b||n))
    {
        for(i=3;i<=n;i++)
        str[i]=(a*str[i-1]+b*str[i-2])%7;
        printf("%d\n",str[n]);
    }
    return 0;
}
       

Number Sequence(杭电1005),布布扣,bubuko.com

Number Sequence(杭电1005)

标签:des   os   io   for   ar   line   amp   ef   

原文地址:http://blog.csdn.net/hdd871532887/article/details/38443575

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!