码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1742 Coins[多重背包可行性]

时间:2016-08-22 23:27:56      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:

 

Coins
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 34814   Accepted: 11828

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn‘t know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony‘s coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

Source

---------------------------
Orz楼爷
多重背包可行性,用O(NV)做法
滚动数组掉N那一维,否则MLE
#include<iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N=105,V=1e5+5;
int n,m,f[V],c[N],v[N],ans=0;

void mpAble(){
    memset(f,-1,sizeof(f));
    f[0]=0;
    for(int i=1;i<=n;i++){
        for(int j=0;j<=m;j++){
            if(f[j]>=0) f[j]=c[i];
            else f[j]=-1;
        }
        for(int j=0;j<=m-v[i];j++)
            if(f[j]>=0)
                f[j+v[i]]=max(f[j+v[i]],f[j]-1);
    }
}
int main(int argc, const char * argv[]) {
    while(cin>>n>>m){
        if(n==0&&m==0) break;
        for(int i=1;i<=n;i++) scanf("%d",&v[i]);
        for(int i=1;i<=n;i++) scanf("%d",&c[i]);
        mpAble();
        for(int i=m;i>=1;i--)if(f[i]>=0) ans++;
        cout<<ans<<"\n";ans=0;
        
    }
    return 0;
}

 

POJ1742 Coins[多重背包可行性]

标签:

原文地址:http://www.cnblogs.com/candy99/p/5797497.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!