码迷,mamicode.com
首页 > 其他好文 > 详细

暑假练习赛 007 B - Weird Cryptography

时间:2016-08-23 23:20:45      阅读:165      评论:0      收藏:0      [点我收藏+]

标签:

Weird Cryptography

Description

standard input/output
Statements

Khaled was sitting in the garden under an apple tree, suddenly! , well... you should guess what happened, an apple fell on his head! , so he came up with a new Cryptography method!! The method deals only with numbers, so... If you want to encode a number, you must represent each of its digits with a set of strings, then the size of the set is the digit itself, No set should contain the same string more than once. For example: the number 42, can be represented with the following two sets: 1) "dog"   "load"   "under"   "nice". 2) "stack"   "dog". The first set contain four strings so it represent the digit 4. The second set contain two strings so it represent the digit 2. Given N strings, what is the smallest number you can get from dividing these strings into non-empty sets, and then decode the result by Khaled‘s Cryptography method? , You must use all the given strings, and no set should contain the same string more than once.

Input

The input consists of several test cases, each test case starts with 0 < N  ≤  10000, the number of the given strings, then follows N space-separated string, each string will contain only lower-case English letters, and the length of each string will not exceeded 100. You can assume that there are no more than nine distinct strings among the given strings. A line containing the number 0 defines the end of the input you should not process this line.

Output

For each test case print a single line in the following format: "Case c: x"   where c is the test case number starting from 1 and x is the solution to the described problem above.

Sample Input

 
Input
3 one two two
7 num go book go hand num num
25 aa aa aa aa aa aa aa aa aa aa aa aa aa aa aa aa aa aa aa aa aa aa aa aa aa
0
Output
Case 1: 12
Case 2: 124
Case 3: 1111111111111111111111111

Sample Output

 

Hint

In the first sample, we divided the given strings into two sets, the first set contains two word: "one"   and "two"   so it represents the digit 2, the second set contains only one word: "two"   so it represent the digit 1.

/*
将单词放进set中会返回一个数,给出n个单词,任意放进set中,让你求返回的数字组成最小数字

思路:先排序,第一次,全放,然后每种个数减一,再放进去,再每种个数减一,以此类推,得出第i大的数字
*/
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<vector>
#include<map>
#define N 10010
using namespace std;
bool cmp(int s1,int s2)
{
    if(s1>s2)
        return true;
    return false;
}
vector<string >v;
int ans[N];
int n;
string s;
int cur[N];
int main()
{
    //freopen("in.txt","r",stdin);
    int p=1;
    while(true)
    {
        v.clear();
        int len=1;
        scanf("%d",&n);
        memset(ans,0,sizeof ans);
        memset(cur,0,sizeof cur);
        if(!n) break;
        //for(int i=0;i<=n;i++)
        //    cout<<ans[i]<<" ";
        //cout<<endl;
        for(int i=0;i<n;i++)
        {
            cin>>s;
            v.push_back(s);
        }
        sort(v.begin(),v.end());
        //cout<<"ok"<<endl;
        for(int i=0;i<n-1;i++)
        {
            if(v[i]==v[i+1])
                ans[len]++;
            else
                ans[len++]++;
        }
        if(v[n-1]==v[n-2])
            ans[len]++;
        else
            ans[++len]++;
        int maxn=-1;
        for(int i=1;i<=len;i++)
        {
            if(maxn<ans[i])
                maxn=ans[i];
            for(int j=0;j<ans[i];j++)
                cur[j]++;
        }
        //cout<<"len="<<len<<endl;
        //for(int i=0;i<=len;i++)
        //    cout<<ans[i]<<" ";
        //cout<<endl;
        //cout<<"len="<<len<<endl;
        printf("Case %d: ",p++);
        for(int i=maxn-1;i>=0;i--)
            printf("%d",cur[i]);
        printf("\n");
        //cout<<endl;
    }
    return 0;
}

 

暑假练习赛 007 B - Weird Cryptography

标签:

原文地址:http://www.cnblogs.com/wuwangchuxin0924/p/5800962.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!