码迷,mamicode.com
首页 > 其他好文 > 详细

题目1459:Prime ring problem

时间:2016-08-26 18:31:36      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:

题目1459:Prime ring problem

时间限制:2 秒

内存限制:128 兆

特殊判题:

提交:1888

解决:794

题目描述:

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.


技术分享

输入:

n (1 < n < 17).

输出:

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.

样例输入:
6
8
样例输出:
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
提示:

用printf打印输出。

#include<iostream>
#include<stdio.h>
#include<queue>
#include<string>
#include<string.h>
using namespace std;



int ans[22];//保存环中每一个被放入的数
bool hash[22];//标记之前已被放入环中的数
int n;
//素数,若需判断一个数是否为素数,则在其中查找,因为输入不大于16,故两数构成的素数必在该数组内。
int prime[]= {2,3,5,7,11,13,17,19,23,29,31,37,41};

bool judge(int x)//判断一个数是否为素数
{
    for(int i=0; i<13; i++)
    {
        if(prime[i]==x) return true;
    }
    return false;
}

void check()//检查输出由回溯法枚举得到的解
{
    if(judge(ans[n]+ans[1])==false) return; //判断最后一个数和第一个数的和是否为素数,若不是则直接返回
    for(int i=1; i<=n; i++)
    {
        if(i!=1)  printf(" ");
        printf("%d",ans[i]);
    }
    printf("\n");
}

void DFS(int num)//递归枚举,num为当前已经放入环中的数字
{
    if(num>1) //当放入的数字大于一个时
    {
        if(judge(ans[num]+ans[num-1])==false)  return ;//判断最后两个数的和是否为素数,若不是则返回继续枚举第num个数
    }
    if(num==n)//若已经放入了n个数
    {
        check();
        return ;
    }
    for(int i=2;i<=n;i++)//放入一个数
    {
      if(hash[i]==false)//若i还没有放入环中
      {
          hash[i]=true;//标记i为已经使用
          ans[num+1]=i;//将这个数放入ans数组中
          DFS(num+1);//继续尝试放入下一个数
          hash[i]=false;//当回溯枚举该位数字时,将i重新标记为未使用
      }
    }
}


int main()
{
    int cas=0;//记录case数
    while(scanf("%d",&n)!=EOF)
    {
        cas++;
        for(int i=0;i<22;i++)//初始化标记所有数字未被使用
        ans[1]=1;
        printf("Case %d:\n",cas);//输出cas数
        hash[1]=true;
        DFS(1);
        printf("\n");
    }
    return 0;
}

 

题目1459:Prime ring problem

标签:

原文地址:http://www.cnblogs.com/zhuoyuezai/p/5811312.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!