码迷,mamicode.com
首页 > 其他好文 > 详细

uva 297 - Quadtrees

时间:2014-08-10 18:22:30      阅读:250      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   strong   

 

 Quadtrees 

A quadtree is a representation format used to encode images. The fundamental idea behind the quadtree is that any image can be split into four quadrants. Each quadrant may again be split in four sub quadrants, etc. In the quadtree, the image is represented by a parent node, while the four quadrants are represented by four child nodes, in a predetermined order.

 

Of course, if the whole image is a single color, it can be represented by a quadtree consisting of a single node. In general, a quadrant needs only to be subdivided if it consists of pixels of different colors. As a result, the quadtree need not be of uniform depth.

 

A modern computer artist works with black-and-white images of bubuko.com,布布扣 units, for a total of 1024 pixels per image. One of the operations he performs is adding two images together, to form a new image. In the resulting image a pixel is black if it was black in at least one of the component images, otherwise it is white.

 

This particular artist believes in what he calls the preferred fullness: for an image to be interesting (i.e. to sell for big bucks) the most important property is the number of filled (black) pixels in the image. So, before adding two images together, he would like to know how many pixels will be black in the resulting image. Your job is to write a program that, given the quadtree representation of two images, calculates the number of pixels that are black in the image, which is the result of adding the two images together.

 

In the figure, the first example is shown (from top to bottom) as image, quadtree, pre-order string (defined below) and number of pixels. The quadrant numbering is shown at the top of the figure.

 

bubuko.com,布布扣

Input Specification

The first line of input specifies the number of test cases (N) your program has to process.

The input for each test case is two strings, each string on its own line. The string is the pre-order representation of a quadtree, in which the letter ‘p‘ indicates a parent node, the letter ‘f‘ (full) a black quadrant and the letter ‘e‘ (empty) a white quadrant. It is guaranteed that each string represents a valid quadtree, while the depth of the tree is not more than 5 (because each pixel has only one color).

 

Output Specification

For each test case, print on one line the text ‘There are X black pixels.‘, where X is the number of black pixels in the resulting image.

 

Example Input

 

3
ppeeefpffeefe
pefepeefe
peeef
peefe
peeef
peepefefe

 

Example Output

 

There are 640 black pixels.
There are 512 black pixels.
There are 384 black pixels.
#include <iostream>
#include <stack>
#include <cstring>
#include <cstdio>
#include <string>
#include <algorithm>
#include <queue>
#include <set>
#include <map>
#include <fstream>
#include <stack>
#include <list>
#include <sstream>

using namespace std;
/*

*/
#define ms(arr, val) memset(arr, val, sizeof(arr))
#define N 10000
#define INF 0x3fffffff
#define vint vector<int>
#define setint set<int>
#define mint map<int, int>
#define lint list<int>
#define sch stack<char>
#define qch queue<char>
#define sint stack<int>
#define qint queue<int>
/*
一张图,只有黑白两色,如果一张图的颜色不一致,则一分为四,直到每一部分只有一个颜色。
现在给了两张分好的图要求合并,如果两张图中相同部分有一张里是黑色,那么合并时这个地方也为黑色,
要求求出黑色在图中的像素点。
*/
char s1[N], s2[N], s3[N];
int p1, p2, p3, ans, lay;

void dfs(char *s, int& p, bool noskip)
{
    if (noskip)
    {
        s3[p3++] = s[p];
    }
    if (s[p++] == p)
    {
        dfs(s, p, noskip);
        dfs(s, p, noskip);
        dfs(s, p, noskip);
        dfs(s, p, noskip);
    }
}
void _union()//合并字符串(处理好的话,可以边处理边计算结果,这里是先合并在计算结果)
{
    while (s1[p1])
    {
        if (s1[p1] == s2[p2])//相等
        {
            s3[p3++] = s1[p1];
            p1++, p2++;
            continue;
        }
        if (s1[p1] == f && s2[p2] == e)//叶子节点
        {
            s3[p3++] = s1[p1];
            p1++, p2++;
            continue;
        }
        if (s1[p1] == e && s2[p2] == f)////叶子节点
        {
            s3[p3++] = s2[p2];
            p1++, p2++;
            continue;
        }
        if (s1[p1] == p && s2[p2] == e)//选用p
        {
            p2++;
            dfs(s1, p1, true);
            continue;
        }
        if (s1[p1] == p && s2[p2] == f)//选用f
        {
            s3[p3++] = s2[p2++];
            dfs(s1, p1, false);
            continue;
        }
        if (s1[p1] == e && s2[p2] == p)//选用p
        {
            p1++;
            dfs(s2, p2, true);
            continue;
        }
        if (s1[p1] == f && s2[p2] == p)//选用f
        {
            s3[p3++] = s1[p1++];
            dfs(s2, p2, false);
            continue;
        }
    }
    s3[p3] = \0;
}
void _dfs()//求值根据s3
{
    if (s3[++p3] == p)
    {
        lay >>= 2;
        _dfs();//first child
        _dfs();//second
        _dfs();//three
        _dfs();//four
        lay <<= 2;
    }
    else
        if (s3[p3] == f)
        {
            ans += lay;
        }
}
int main()
{
    int n;
    scanf("%d", &n);
    getchar();
    while (n--)
    {
        gets(s1 + 1);
        gets(s2 + 1);
        p1 = p2 = p3 = 1;
        ans = 0;
        lay = 1024;
        _union();
        p3 = 0;
        _dfs();
        printf("There are %d black pixels.\n", ans);
    }
    return 0;
}

 

uva 297 - Quadtrees,布布扣,bubuko.com

uva 297 - Quadtrees

标签:des   style   blog   http   color   os   io   strong   

原文地址:http://www.cnblogs.com/jecyhw/p/3903016.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!