码迷,mamicode.com
首页 > 其他好文 > 详细

Phone List(字典树)

时间:2014-08-10 18:44:40      阅读:284      评论:0      收藏:0      [点我收藏+]

标签:字典树   hdu   

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10321    Accepted Submission(s): 3543


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
NO YES
这题用了两种方法,一种是把他们排序,再相邻两个进行比较,如果发现有包涵关系立马退出,例外一种是用字典树进行匹配
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
typedef struct Trie{
   int v;
   Trie *next[10];
}Trie;
Trie *root;
bool flag;
void inti()//初始化
{
    root = (Trie *)malloc(sizeof(Trie));
    root->v=0;
    for(int i=0;i<10;i++)
        root->next[i]=NULL;
}
void Create(char *str)//插入
{
    int len=strlen(str);
    Trie *p = root,*q;
    for(int i=0;i<len;i++)
    {
        int id=str[i]-'0';
        if(p->next[id]==NULL)
        {
            q = (Trie *)malloc(sizeof(Trie));
            q -> v = 0;
            for(int i=0;i<10;i++)
            {
                q->next[i]=NULL;
            }
            p->next[id]=q;

        }
        else
        {
            if(p->next[id]->v==1||str[i+1]=='\0')//表示字典树中包涵这个串的子串
            {
                flag=true;
                return ;
            }
        }
       p=p->next[id];
    }
    p->v=1;
}
void Shifang(Trie *p)//释放内存
{
    if(p==NULL)return ;
    for(int i=0;i<10;i++)
    {
        if(p->next[i]!=NULL)
            Shifang(p->next[i]);
    }
    free(p);
    return ;
}
int main()
{
   char str[100];
   int t,n;

   scanf("%d",&t);
   while(t--)
   {    inti();
       flag=false;
       scanf("%d",&n);
       for(int i=0;i<n;i++)
       {
           scanf("%s",&str);
           if(!flag)Create(str);
       }
       if(!flag)printf("YES\n");
       else printf("NO\n");
       Shifang(root);//必须加这个,不然会爆的
   }
   return 0;
}





#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>
#include <algorithm>
using namespace std;
string s[10004];
int n;
int fun()
{
    int i,j;
    for(i=1;i<n;i++)
    {
        int len=s[i-1].length();
        for(j=0;j<len;j++)
        {
            if(s[i][j]!=s[i-1][j])break;
        }
        if(j>=len)return false;
    }
    return true;
}
int main()
{
   int t;
   scanf("%d",&t);
   while(t--)
   {
       scanf("%d",&n);
       for(int i=0;i<n;i++)
         cin>>s[i];
       sort(s,s+n);
       if(fun())
        cout<<"YES"<<endl;
       else cout<<"NO"<<endl;
   }
   return 0;
}


Phone List(字典树),布布扣,bubuko.com

Phone List(字典树)

标签:字典树   hdu   

原文地址:http://blog.csdn.net/zhangweiacm/article/details/38471033

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!