码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2239(二分图最大匹配)

时间:2016-09-03 18:03:19      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:

Selecting Courses
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10222   Accepted: 4616

Description

It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming is a student who loves study every much, and at the beginning of each term, he always wants to select courses as more as possible. Of course there should be no conflict among the courses he selects. 

There are 12 classes every day, and 7 days every week. There are hundreds of courses in the college, and teaching a course needs one class each week. To give students more convenience, though teaching a course needs only one class, a course will be taught several times in a week. For example, a course may be taught both at the 7-th class on Tuesday and 12-th class on Wednesday, you should assume that there is no difference between the two classes, and that students can select any class to go. At the different weeks, a student can even go to different class as his wish. Because there are so many courses in the college, selecting courses is not an easy job for Li Ming. As his good friends, can you help him? 

Input

The input contains several cases. For each case, the first line contains an integer n (1 <= n <= 300), the number of courses in Li Ming‘s college. The following n lines represent n different courses. In each line, the first number is an integer t (1 <= t <= 7*12), the different time when students can go to study the course. Then come t pairs of integers p (1 <= p <= 7) and q (1 <= q <= 12), which mean that the course will be taught at the q-th class on the p-th day of a week.

Output

For each test case, output one integer, which is the maximum number of courses Li Ming can select.

Sample Input

5
1 1 1
2 1 1 2 2
1 2 2
2 3 2 3 3
1 3 3

Sample Output

4
思路:将课程号与上课时间(p,q)分别最为二分图中,两个集合中的结点。将(p,q)表示为q*10+p可唯一标记一节课。
#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;
const int MAXN=605;
vector<int> arc[MAXN];
int n;
int match[MAXN],vis[MAXN];
bool dfs(int u)
{
    for(int i=0;i<arc[u].size();i++)
    {
        int to=arc[u][i];
        if(!vis[to])    
        {
            vis[to]=1;
            int w=match[to];
            if(w==-1||dfs(w))
            {
                match[to]=u;
                match[u]=to;
                return true;
            }
        }
    }
    return false;
}
int max_flow()
{
    int ans=0;
    memset(match,-1,sizeof(match));
    for(int i=1;i<=n;i++)
    {
        if(match[i]==-1)
        {
            memset(vis,0,sizeof(vis));
            if(dfs(i))    ans++;
        }
    }
    return ans;
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<MAXN;i++)    arc[i].clear();
        for(int i=1;i<=n;i++)
        {
            int s;
            scanf("%d",&s);
            for(int j=0;j<s;j++)
            {
                int p,q;
                scanf("%d%d",&p,&q);
                int v=q*10+p;
                v+=n;
                arc[i].push_back(v);
                arc[v].push_back(i);
            }
        }
        int res=max_flow();
        printf("%d\n",res);        
    }
    return 0;
}

 



POJ2239(二分图最大匹配)

标签:

原文地址:http://www.cnblogs.com/program-ccc/p/5837506.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!