码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3041 Asteroids

时间:2016-09-14 09:36:10      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:

Asteroids

 

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
 
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
#define pb push_back
using namespace std;
int k,n,link[505],vis[505];
vector<int>G[505];
bool dfs(int u)
{
    for(int len=G[u].size(),i=0;i<len;i++)
    {
        int v=G[u][i];
        if(!vis[v])
        {
            vis[v]=1;
            if(link[v]==-1||dfs(link[v]))
            {
                link[v]=u;
                return 1;
            }
        }
    }
    return 0;
}
int match()
{
    int ans=0;
    memset(link,-1,sizeof(link));
    for(int i=1;i<=n;i++)
    {
        memset(vis,0,sizeof(vis));
        if(dfs(i))ans++;
    }
    return ans;
}
int main()
{
    scanf("%d%d",&n,&k);
    for(int i=0;i<=n;i++)G[i].clear();
    while(k--)
    {
        int u,v;
        scanf("%d%d",&u,&v);
        G[u].pb(v);
    }
    printf("%d\n",match());
    return 0;
}

 

poj 3041 Asteroids

标签:

原文地址:http://www.cnblogs.com/homura/p/5870552.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!