码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ5437(优先队列)

时间:2016-09-15 21:36:09      阅读:172      评论:0      收藏:0      [点我收藏+]

标签:

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 5471    Accepted Submission(s): 1370


Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the nth person to enter her castle is.
 

 

Input
The first line of the input gives the number of test cases, T , where 1T15.

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1k150,000. The door would open m times before all Alisha’s friends arrive where 0mk. Alisha will have q queries where 1q100.

The ith of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi1vi108, separated by a blank. Bi is the name of the ith person coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines contains two integers t(1tk) and p(0pk) separated by a blank. The door will open right after the tth person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1th,...,nqth friends to enter her castle.

Note: there will be at most two test cases containing n>10000.
 

 

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

 

Sample Input
1
5 2 3
Sorey 3
Rose 3
Maltran 3
Lailah 5
Mikleo 6
1 1
4 2
1 2 3
 

 

Sample Output
Sorey Lailah Rose
思路:直接用优先队列模拟。注意:m可以为0。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <string>
using namespace std;
const int MAXN=150005;
struct Node{
    char name[205];
    int val,id;
    Node(){}
    bool operator<(const Node &nod) const
    {
        if(val!=nod.val)    return val < nod.val;
        else    return id > nod.id;
    }
}node[MAXN];
struct Query{
    int t,q;
}que[MAXN];
int n,m,q;
int query[MAXN];
bool comp(Query q1,Query q2)
{
    return q1.t < q2.t;
}
int res[MAXN],tot;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        tot=0;
        scanf("%d%d%d",&n,&m,&q);
        for(int i=1;i<=n;i++)
        {
            scanf("%s %d",node[i].name,&node[i].val);
            node[i].id=i;
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&que[i].t,&que[i].q);
        }
        int mx=0;
        for(int i=0;i<q;i++)
        {
            scanf("%d",&query[i]);
            mx=max(mx,query[i]);
        }
        sort(que,que+m,comp);
        priority_queue<Node> pque;
        for(int i=1,j=0;i<=n;i++)
        {
            pque.push(node[i]);
            if(j<m&&i==que[j].t)
            {
                for(int l=0;l<que[j].q&&!pque.empty();l++)
                {
                    Node nod=pque.top();pque.pop();
                    res[++tot]=nod.id;
                }
                j++;
            }
            if(tot>=mx)    break;
        }
        while(!pque.empty())
        {
            Node nod=pque.top();pque.pop();
            res[++tot]=nod.id;
            if(tot>=mx)    break;
        }
        for(int i=0;i<q-1;i++)
        {
            printf("%s ",node[res[query[i]]].name);
        }
        printf("%s\n",node[res[query[q-1]]].name);
    }
    return 0;
}

 

HDOJ5437(优先队列)

标签:

原文地址:http://www.cnblogs.com/program-ccc/p/5875276.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!