码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2588 GCD (欧拉函数)

时间:2014-08-12 13:49:14      阅读:193      评论:0      收藏:0      [点我收藏+]

标签:hdu   数论   

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1013    Accepted Submission(s): 457



Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 

Output
For each test case,output the answer on a single line.
 

Sample Input
3 1 1 10 2 10000 72
 

Sample Output
1 6 260
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1695 1787 3501 2824 2582

模板题目,新手对数论理解有限,求指导。

题意:

分析:假设x<=n,n=p*d,x=q*d.假设n与x的最大公约数为d,则能够推出p与q肯定是互质的,因为x<=n所以要求的就是p的欧拉函数值了,那么我们就转化成求满足:n=p*d,并且d>=m的p的欧拉函数值之和了。

代码实现:

#include <cstring>
#include <cstdio>
int OL(int n)   //大白书上的求一个数的欧拉函数模板。
{
    int res=n,i,j;
    for(i=2;i*i<=n;i++)
    {
        if(n%i==0)
        {
           // n/=i;
            while(!(n%i)) n/=i;
            res=res/i*(i-1);
        }
    }
    if(n!=1) res=res/n*(n-1);
return res;
}
int main()
{
    int n,i,j,m,sum,T;
    while(scanf("%d",&T)!=EOF)
    {
        while(T--)
        {
            sum=0;
            scanf("%d%d",&n,&m);
            for(i=1;i*i<=n;i++)
            if(n%i==0)
            {
                if(i>=m)
                sum+=OL(n/i);
                if((n/i)!=i && (n/i)>=m)
                sum+=OL(i);
            }
         printf("%d\n",sum);
        }
    }
    return 0;
}


 

HDU 2588 GCD (欧拉函数),布布扣,bubuko.com

HDU 2588 GCD (欧拉函数)

标签:hdu   数论   

原文地址:http://blog.csdn.net/qq2256420822/article/details/38511473

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!