码迷,mamicode.com
首页 > 其他好文 > 详细

UVALive 6661 - Equal Sum Sets

时间:2016-10-07 18:07:12      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:

Let us consider sets of positive integers less than or equal to n. Note that all elements of a set are different. Also note that the order of elements doesnt matter, that is, both {3, 5, 9} and {5, 9, 3} mean the same set.

Specifying the number of set elements and their sum to be k and s, respectively, sets satisfying the conditions are limited. When n = 9, k = 3 and s = 23, {6, 8, 9} is the only such set. There may be more than one such set, in general, however. When n = 9, k = 3 and s = 22, both {5, 8, 9} and {6, 7, 9} are possible.

You have to write a program that calculates the number of the sets that satisfy the given conditions

Input

The input consists of multiple datasets. The number of datasets does not exceed 100. Each of the datasets has three integers n, k and s in one line, separated by a space. You may assume 1 ≤ n ≤ 20, 1 ≤ k ≤ 10 and 1 ≤ s ≤ 155. The end of the input is indicated by a line containing three zeros

Output

The output for each dataset should be a line containing a single integer that gives the number of the sets that satisfy the conditions. No other characters should appear in the output. You can assume that the number of sets does not exceed 2^31 − 1.

Sample Input

9 3 23

Sample Output

1

题目大意就是给出最大值 n 给出个数 k 给出和 s   让你找出k个1~n中的数  使得这k个数的和为s

//dp[i][j][k]
//i个数 最大值为j 和为k的方案数   转移  dp[i][j][k]+=dp[i-1][j][k]+dp[i][j-1][k-j];

/* ***********************************************
Author        :guanjun
Created Time  :2016/10/7 14:20:37
File Name     :La6661.cpp
************************************************ */
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <iomanip>
#include <list>
#include <deque>
#include <stack>
#define ull unsigned long long
#define ll long long
#define mod 90001
#define INF 0x3f3f3f3f
#define maxn 10010
#define cle(a) memset(a,0,sizeof(a))
const ull inf = 1LL << 61;
const double eps=1e-5;
using namespace std;
priority_queue<int,vector<int>,greater<int> >pq;
struct Node{
    int x,y;
};
struct cmp{
    bool operator()(Node a,Node b){
        if(a.x==b.x) return a.y> b.y;
        return a.x>b.x;
    }
};

bool cmp(int a,int b){
    return a>b;
}
//dp[i][j][k]
//i个数 最大值为j 和为k的方案数
int dp[11][25][200];
int main()
{
    #ifndef ONLINE_JUDGE
    //freopen("in.txt","r",stdin);
    #endif
    //freopen("out.txt","w",stdout);
    int n,K,s;
    while(cin>>n>>K>>s){
        if(n==0&&K==0&&s==0)break;
        cle(dp);
        for(int j=1;j<=20;j++){
            dp[1][j][j]=1;
            dp[0][j][0]=1;
        }
        dp[1][1][1]=1;
        for(int i=1;i<=K;i++){
            for(int j=2;j<=n;j++){
                for(int k=1;k<=i*j;k++){
                    dp[i][j][k]=dp[i][j-1][k];
                    if(k>=j)dp[i][j][k]+=dp[i-1][j-1][k-j];

                }
            }
        }
        cout<<dp[K][n][s]<<endl;
    }
    return 0;
}

 

UVALive 6661 - Equal Sum Sets

标签:

原文地址:http://www.cnblogs.com/pk28/p/5936161.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!