码迷,mamicode.com
首页 > 其他好文 > 详细

HDU - 4939 Stupid Tower Defense

时间:2014-08-13 13:14:47      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   os   io   for   ar   2014   

Problem Description
FSF is addicted to a stupid tower defense game. The goal of tower defense games is to try to stop enemies from crossing a map by building traps to slow them down and towers which shoot at them as they pass.

The map is a line, which has n unit length. We can build only one tower on each unit length. The enemy takes t seconds on each unit length. And there are 3 kinds of tower in this game: The red tower, the green tower and the blue tower.

The red tower damage on the enemy x points per second when he passes through the tower.

The green tower damage on the enemy y points per second after he passes through the tower.

The blue tower let the enemy go slower than before (that is, the enemy takes more z second to pass an unit length, also, after he passes through the tower.)

Of course, if you are already pass through m green towers, you should have got my damage per second. The same, if you are already pass through k blue towers, the enemy should have took t + kz seconds every unit length.

FSF now wants to know the maximum damage the enemy can get.

Input
There are multiply test cases.

The first line contains an integer T (T<=100), indicates the number of cases.

Each test only contain 5 integers n, x, y, z, t (2<=n<=1500,0<=x, y, z<=60000,1<=t<=3)

Output
For each case, you should output "Case #C: " first, where C indicates the case number and counts from 1. Then output the answer. For each test only one line which have one integer, the answer to this question.

Sample Input

1 2 4 3 2 1

Sample Output

Case #1: 12
Hint
For the first sample, the first tower is blue tower, and the second is red tower. So, the total damage is 4*(1+2)=12 damage points.
bubuko.com,布布扣

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
typedef __int64 ll;
using namespace std;
const int maxn = 1510;

ll dp[maxn][maxn];
ll n, x, y, z, t;

int main() {
	int Cas;
	scanf("%d", &Cas);
	for (int cas = 1; cas <= Cas; cas++) {
		scanf("%I64d%I64d%I64d%I64d%I64d", &n, &x, &y, &z, &t);
		memset(dp, 0, sizeof(dp));
		ll ans = n * x * t;
		for (ll i = 1; i <= n; i++) {
			for (ll j = 0; j <= i; j++) {
				if (j == 0)
					dp[i][j] = dp[i-1][j] + (i-1-j) * t * y;
				else dp[i][j] = max(dp[i-1][j-1]+(i-j)*y*(t+(j-1)*z), dp[i-1][j]+(i-1-j)*y*(t+j*z));
				ans = max(ans, dp[i][j] + (n-i)*(j*z+t)*(x+(i-j)*y));
			}
		}
		printf("Case #%d: ", cas);
		printf("%I64d\n", ans);
	}
	return 0;
}



HDU - 4939 Stupid Tower Defense,布布扣,bubuko.com

HDU - 4939 Stupid Tower Defense

标签:des   blog   http   os   io   for   ar   2014   

原文地址:http://blog.csdn.net/u011345136/article/details/38533283

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!