码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2886 Who Gets the Most Candies?(线段树+约瑟夫环+反素数)

时间:2014-08-13 22:33:17      阅读:281      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   使用   os   io   strong   for   

Who Gets the Most Candies?
Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 9934   Accepted: 3050
Case Time Limit: 2000MS

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (?A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 500,000) and K (1 ≤ K ≤ N) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 3


题解及代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <set>
#include <map>
#include <queue>
#include <string>
#define maxn 500010
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define ALL %I64d
using namespace std;
typedef long long  ll;
int pos,ans;      //pos记录每次跳出的人的所处的叶子节点的位置,ans为最后输出最大的F(k)的值

const int antiprime[] = {1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,1260,1680,2520,5040,7560,10080,15120,20160,25200,27720,45360,50400,55440,83160,110880,166320, 221760, 277200, 332640, 498960, 554400, 665280};
const int factorNum[] = {1, 2, 3, 4, 6, 8, 9, 10, 12, 16, 18, 20, 24, 30, 32, 36, 40, 48, 60, 64, 72, 80, 84, 90, 96, 100, 108, 120, 128, 144, 160, 168, 180, 192, 200, 216, 224};


int find_max(int n,int &x)   //寻找1--n中最大的F(k)值,并返回k
{
    int i=0;
    while(i<35)
    {
        if(antiprime[i]>n)
            break;
        i++;
    }
    x=factorNum[i-1];
    return antiprime[i-1];
}


struct segment     //定义线段树的节点
{
    int l,r;
    int value;
    char s[12];    //叶子节点中信息,非叶子节点无用
    int dir;       //读者也可以去掉这里,自行优化空间
} son[maxn*3];

void PushUp(int rt)
{
    son[rt].value=son[rt<<1].value+son[rt<<1|1].value;
}

void Build(int l,int r,int rt)
{
    son[rt].l=l;
    son[rt].r=r;
    if(l==r)
    {
        scanf("%s%d",son[rt].s,&son[rt].dir);
        son[rt].value=1;
        return;
    }
    int m=(l+r)/2;
    Build(lson);
    Build(rson);
    PushUp(rt);
}


void Update(int w,int rt)      //查找跳出的人的叶子节点
{
    if(son[rt].l==son[rt].r)
    {
        son[rt].value=0;       //标记为跳出
        pos=rt;                //记录叶子节点的位置,下一次计算查找的位置要用到son[rt].dir
        return;
    }

    int m=(son[rt].l+son[rt].r)/2;

    if(son[rt<<1].value>w)
        Update(w,rt<<1);
    else
    {
        w-=son[rt<<1].value;
        Update(w,rt<<1|1);
    }
    PushUp(rt);
}

int main()
{
    int n,fpos;
    while(scanf("%d%d",&n,&fpos)!=EOF)
    {
        Build(1,n,1);

        fpos--;
        int m=find_max(n,ans);

        //printf("%d %d\n",m,ans);
        for(int i=1;i<=m;i++)
        {
            Update(fpos,1);
            //printf("%s\n",son[pos].s);
            if(n!=i)
            {
                if(son[pos].dir>0)                                      //这里分成向左跳和向右跳两种情况,开始总是出错
                fpos=((fpos+son[pos].dir-1)%(n-i)+(n-i))%(n-i);         //后来仔细想了一下,当我们向右跳的时候,去除改点
                else fpos=((fpos+son[pos].dir)%(n-i)+(n-i))%(n-i);      //之后没一点都相当于向前移动一个位置
            }                                                           //而向前跳,改点删除之后,后面的点向前移动,而前面的点不用
        }                                                                //读者可以自己模拟一下跳出后每个点的下标就好了
        printf("%s %d\n",son[pos].s,ans);
    }
    return 0;
}
/*
这道题的意思就是一个约瑟夫环的变形问题,当我们跳到某个点的时候根据当前值向左或者向右跳。
然后记录第i个跳出的人的糖果数为F(i),然后在求出F(i)的最大值和对应的人是谁。

这里我们可以预先处理出F(1)--F(n)的最大值为F(k),然后再找到第k个跳出来的人是谁就可以了。
这里F(i)的定义是i的因子的数目,求1--n中因子数最多的数k就是就小于n最大的反素数是谁。
那么我们就可以是用模版预先处理出反素数的序列,以及他们对应的因子数的个数。

然后对于n,找出最大的反素数k,那么这个k代表我们要求出第k个跳出来的人思谁。

这里我们使用能够线段树来维护某段区间中,未跳出的人的数目,然后每次查找到跳出的人是谁,
标记为跳出,维护区间人数,计算下一个跳出的人的位置,循环直到找到第k个人。

*转载请注明出处,谢谢。
*/








poj 2886 Who Gets the Most Candies?(线段树+约瑟夫环+反素数),布布扣,bubuko.com

poj 2886 Who Gets the Most Candies?(线段树+约瑟夫环+反素数)

标签:des   style   color   使用   os   io   strong   for   

原文地址:http://blog.csdn.net/knight_kaka/article/details/38541705

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!