码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3282 Ferry Loading IV(简单模拟)

时间:2014-08-14 20:34:49      阅读:349      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   for   ar   

Description

Before bridges were common, ferries were used to transport cars across rivers. River ferries, unlike their larger cousins, run on a guide line and are powered by the river‘s current. Cars drive onto the ferry from one end, the ferry crosses the river, and the cars exit from the other end of the ferry.

There is an l-meter-long ferry that crosses the river. A car may arrive at either river bank to be transported by the ferry to the opposite bank. The ferry travels continuously back and forth between the banks so long as it is carrying a car or there is at least one car waiting at either bank. Whenever the ferry arrives at one of the banks, it unloads its cargo and loads up cars that are waiting to cross as long as they fit on its deck. The cars are loaded in the order of their arrival; ferry‘s deck accommodates only one lane of cars. The ferry is initially on the left bank where it broke and it took quite some time to fix it. In the meantime, lines of cars formed on both banks that await to cross the river.

Input

The first line of input contains c, the number of test cases. Each test case begins with l, mm lines follow describing the cars that arrive in this order to be transported. Each line gives the length of a car (in centimeters), and the bank at which the car arrives ("left" or "right").

Output

For each test case, output one line giving the number of times the ferry has to cross the river in order to serve all waiting cars.

Sample Input

4
20 4
380 left
720 left
1340 right
1040 left
15 4 
380 left
720 left
1340 right
1040 left
15 4 
380 left
720 left
1340 left
1040 left
15 4 
380 right
720 right
1340 right
1040 right

Sample Output

3
3
5
6

简单模拟,最后20分钟开的这道题,写的急了,wa了3发,真想骂自己SB。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
#include<queue>
using namespace std;
int t,len,n;

int main()
{
   char str[15];
   int x;
   scanf("%d",&t);
   while(t--)
   {
       queue<int>l;
       queue<int>r;
       scanf("%d%d",&len,&n);
       for(int i=0;i<n;i++)
       {
           scanf("%d%s",&x,str);
           if(str[0]=='l')
              l.push(x);
           else
              r.push(x);
       }
       int d=1;//记录船在哪边1代表左
       int num=0;
       while(!l.empty()||!r.empty())
       {
           int sum=len*100;
           if(d==1)
           {
               int s=0;
               while(!l.empty()&&s+l.front()<=sum)
               {
                   s+=l.front();
                   l.pop();
               }
               d=-d;
               num++;
           }
           else
           {
               int s=0;
               while(!r.empty()&&s+r.front()<=sum)
               {
                   s+=r.front();
                   r.pop();
               }
               d=-d;
               num++;
           }
       }
       printf("%d\n",num);
   }
   return 0;
}

POJ 3282 Ferry Loading IV(简单模拟),布布扣,bubuko.com

POJ 3282 Ferry Loading IV(简单模拟)

标签:des   style   http   color   os   io   for   ar   

原文地址:http://blog.csdn.net/u013582254/article/details/38563461

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!