码迷,mamicode.com
首页 > 其他好文 > 详细

hdu4950Monster

时间:2014-08-14 20:45:19      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   java   os   io   strong   

Monster

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 60 Accepted Submission(s): 34


Problem Description
Teacher Mai has a kingdom. A monster has invaded this kingdom, and Teacher Mai wants to kill it.

Monster initially has h HP. And it will die if HP is less than 1.

Teacher Mai and monster take turns to do their action. In one round, Teacher Mai can attack the monster so that the HP of the monster will be reduced by a. At the end of this round, the HP of monster will be increased by b.

After k consecutive round‘s attack, Teacher Mai must take a rest in this round. However, he can also choose to take a rest in any round.

Output "YES" if Teacher Mai can kill this monster, else output "NO".

Input
There are multiple test cases, terminated by a line "0 0 0 0".

For each test case, the first line contains four integers h,a,b,k(1<=h,a,b,k <=10^9).

Output
For each case, output "Case #k: " first, where k is the case number counting from 1. Then output "YES" if Teacher Mai can kill this monster, else output "NO".

Sample Input
5 3 2 2 0 0 0 0

Sample Output
Case #1: NO

Source
#include<stdio.h>
int main()
{
    __int64 h,a,b,k,t=0;
    while(scanf("%I64d%I64d%I64d%I64d",&h,&a,&b,&k)>0)
    {
        if(!h&&!a&&!b&&!k)
        break;
        printf("Case #%d: ",++t);
        if(h<=a||h-(a-b)*(k-1)-a<=0)printf("YES\n");
        else if(a<=b||h-(a-b)*k+b>=h)printf("NO\n");
        else printf("YES\n");
    }
}


hdu4950Monster,布布扣,bubuko.com

hdu4950Monster

标签:des   style   http   color   java   os   io   strong   

原文地址:http://blog.csdn.net/u010372095/article/details/38561925

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!