码迷,mamicode.com
首页 > 其他好文 > 详细

18002 Z-Scan 模拟题

时间:2016-11-11 14:45:25      阅读:275      评论:0      收藏:0      [点我收藏+]

标签:script   ges   out   efi   code   str   eth   type   格式   

18002 Z-Scan

时间限制:1000MS  内存限制:65535K
提交次数:0 通过次数:0

题型: 编程题   语言: 不限定

 

Description

Z-Scan is a method to scan data in a square matrix(矩阵). Fig.1 shows Z-Scan. Here, the number stands for 
the scan sequence number of the element.
技术分享
Our question is very simple. Given the size (n * n) of the square matrix and the row and column of the matrix element, 
could you tell me the scan sequence number of the element?




输入格式

The first line is an integer N, the number of cases, 1<=N<=10
N lines follow. Each line contains 3 integers(n r c), The "n" stands for a square matrix in size of n * n.
The "r" is the row of the element. The "c" is the column of the element.  1 <= r, c <= n <= 100 



输出格式

For each case, output the scan sequence number of the element.



 

输入样例

3
5 1 2
5 4 5
99 99 99



 

输出样例

2
23
9801



 

来源

 Mr. Chen 

 

作者

 admin

 

模拟题打表,模拟的时候用dfs模拟

技术分享

注意到只有两种方向,

一种是x + 1, y - 1

一种是x - 1, y + 1

其他那些向下和向左,是作为边界来处理的。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
#define IOS ios::sync_with_stdio(false)
using namespace std;
#define inf (0x3f3f3f3f)
typedef long long int LL;

#include <iostream>
#include <sstream>
#include <vector>
#include <set>
#include <map>
#include <queue>
#include <string>
int n, r, c;
const int maxn = 1e2 + 20;
int a[maxn][maxn];
int tonext[2][2] = {{1, -1}, {-1, 1}};
void dfs(int num, int x, int y, int now) {
    a[x][y] = num;
    if (x == n && y == n) return;
    if (now == 0) { //减y的
        if (y == 1 && x != n) {
            dfs(num + 1, x + 1, y, !now);
        } else if (x == n) {
            dfs(num + 1, x, y + 1, !now);
        } else {
            dfs(num + 1, x + tonext[now][0], y + tonext[now][1], now);
        }
    } else { //减x的
        if (x == 1 && y != n) {
            dfs(num + 1, x, y + 1, !now);
        } else if (y == n) {
            dfs(num + 1, x + 1, y, !now);
        } else {
            dfs(num + 1, x + tonext[now][0], y + tonext[now][1], now);
        }
    }
}
void work() {
    scanf("%d%d%d", &n, &r, &c);
    a[1][1] = 1;
    dfs(2, 1, 2, 0);
//    for (int i = 1; i <= n; ++i) {
//        for (int j = 1; j <= n; ++j) {
//            printf("%d ", a[i][j]);
//        }
//        printf("\n");
//    }
    printf("%d\n", a[r][c]);
}

int main() {
#ifdef local
    freopen("data.txt","r",stdin);
#endif
    int t;
    scanf("%d", &t);
    while (t--) work();
    return 0;
}

 

18002 Z-Scan 模拟题

标签:script   ges   out   efi   code   str   eth   type   格式   

原文地址:http://www.cnblogs.com/liuweimingcprogram/p/6053852.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!