码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3670 Eating Together

时间:2014-08-15 17:56:49      阅读:205      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   数据   for   

Description

The cows are so very silly about their dinner partners. They have organized themselves into three groups (conveniently numbered 1, 2, and 3) that insist upon dining together. The trouble starts when they line up at the barn to enter the feeding area.

Each cow i carries with her a small card upon which is engraved Di (1 ≤ Di ≤ 3) indicating her dining group membership. The entire set of N (1 ≤ N ≤ 30,000) cows has lined up for dinner but it‘s easy for anyone to see that they are not grouped by their dinner-partner cards.

FJ‘s job is not so difficult. He just walks down the line of cows changing their dinner partner assignment by marking out the old number and writing in a new one. By doing so, he creates groups of cows like 111222333 or 333222111 where the cows‘ dining groups are sorted in either ascending or descending order by their dinner cards.

FJ is just as lazy as the next fellow. He‘s curious: what is the absolute mminimum number of cards he must change to create a proper grouping of dining partners? He must only change card numbers and must not rearrange the cows standing in line.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i describes the i-th cow‘s current dining group with a single integer: Di

Output

* Line 1: A single integer representing the minimum number of changes that must be made so that the final sequence of cows is sorted in either ascending or descending order

Sample Input

5
1
3
2
1
1

Sample Output

1

Source


题意:将不同编号的牛改成升序123降序321的最小操作步骤。数据30000,用nlogn的方法。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
using namespace std;
const int maxn=30001;
int num[maxn],s[maxn];

int main()
{
    int n,len1,len2;
    int l,r,mid;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
            scanf("%d",&num[i]);
        memset(s,0,sizeof(s));
        s[0]=-1;
        len1=0;
        for(int i=0;i<n;i++)//升123
        {
            if(num[i]>=s[len1])
                s[++len1]=num[i];
            else
            {
                l=1,r=len1;
                while(l<=r)
                {
                    mid=(l+r)>>1;
                    if(num[i]>=s[mid])
                        l=mid+1;
                    else
                        r=mid-1;
                }
                s[l]=num[i];
            }
        }
        memset(s,0,sizeof(s));
        len2=0;
        s[0]=INT_MAX;
        for(int i=0;i<n;i++)//降321
        {
            if(s[len2]>=num[i])
                s[++len2]=num[i];
            else
            {
                l=1,r=len2;
                while(l<=r)
                {
                    mid=(l+r)>>1;
                    if(num[i]<=s[mid])
                        l=mid+1;
                    else
                        r=mid-1;
                }
                s[l]=num[i];
            }
        }
        int ans=n-max(len1,len2);
        printf("%d\n",ans);
    }
    return 0;
}


POJ 3670 Eating Together,布布扣,bubuko.com

POJ 3670 Eating Together

标签:des   style   http   color   os   io   数据   for   

原文地址:http://blog.csdn.net/u013582254/article/details/38587243

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!