码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1151 Air Raid(最小路径覆盖 = 顶点数 - 最大匹配数)

时间:2014-08-15 21:13:29      阅读:407      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   for   ar   

Air Raid

Problem Description
Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town‘s streets you can never reach the same intersection i.e. the town‘s streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.
 

Input
Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town‘s streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.
 

Output
The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.
 

Sample Input
2 4 3 3 4 1 3 2 3 3 3 1 3 1 2 2 3
 

Sample Output
2 1
 

Source
 

Recommend

题意:在一个城市,所有的街道连接方式都是单向的,但是每个街道都是从一个十字路口连接到另一个十字路口,已知说不存在回路。

一些伞兵要走遍小镇的所有十字路口,且每个十字路口只有一个伞兵去。

求最少的伞兵数,即 最小路径覆盖


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <math.h>
#define init(a) memset(a,0,sizeof(a))
#define PI acos(-1,0)
using namespace std;
const int maxn = 310;
const int maxm = 100001;
#define lson left, m, id<<1
#define rson m+1, right, id<<1|1
#define min(a,b) (a>b)?b:a
#define max(a,b) (a>b)?a:b
#define maxx 0x3f3f3f3f
const int N = 50010;
int ma[maxn][maxn];
int line[maxn];
bool vis[maxn];
int k,n,m;

int DFS(int u)
{
    for(int v = 1;v<=n;v++)
    {
        if(vis[v]==0 && ma[u][v]==1)
        {
            vis[v] = 1;
            if(line[v]==-1 || DFS(line[v]))
            {
                line[v] = u;
                return 1;
            }
        }
    }
    return 0;
}
int K_M()
{
    int ans = 0;
    memset(line,-1,sizeof(line));
    for(int i = 1;i<=n;i++)
    {
        init(vis);
        ans+=DFS(i);
    }
    return ans;
}
int main()
{
    int x,y,z;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        init(ma);
        for(int i = 1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            ma[x][y] = 1;
        }
        int ans = K_M();
        //最小路径覆盖 = 顶点数 - 最大匹配数
        printf("%d\n",n-ans);
    }
    return 0;
}


HDU 1151 Air Raid(最小路径覆盖 = 顶点数 - 最大匹配数),布布扣,bubuko.com

HDU 1151 Air Raid(最小路径覆盖 = 顶点数 - 最大匹配数)

标签:des   style   http   color   os   io   for   ar   

原文地址:http://blog.csdn.net/wjw0130/article/details/38589697

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!