码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3087 Shuffle'm Up(模拟)

时间:2014-08-16 17:12:00      阅读:214      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   strong   for   

Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

bubuko.com,布布扣

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (?1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1

Source




题意: 给你a,b,c三堆牌,b放一张,a放一张,放成一堆新的牌,这样看能不能放成c,如果不能,那么底下的牌(数量已知)为a,上面为b,继续重复,

如果能放成功,输出次数,否则-1


模拟题,解释在代码



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

string ss,e,s;
int ans,len;

void bfs()
{
    if(ans&&s==ss) //如果和第一次想同,不可能成功,死循环
        return ;

    if(s==e)  //放成功了
        return ;

    ++ans; //仿牌次数增加

    int i,j;
    string a,b;

    a=b="";
    for(i=0;i<len;i++)
        a+=s[i];   

    for(;i<len*2;i++)
        b+=s[i];

     s="";
    for(i=0;i<len;i++)
    {
        s+=b[i]; //先b
        s+=a[i];  //后a
    }

    bfs();
}

int main()
{
    int t,ca=0;
    int i,j;
    string a,b;

    scanf("%d",&t);
    while(t--)
    {
       cin>>len>>b>>a>>e; //不好意思,我是输入的b,a
       ans=0;
       s="";
       for(i=0;i<len;i++)  //这是第一次放牌,所以后面输出ans+1
       {
           s+=a[i];
           s+=b[i];
       }

        ss=s;
        bfs();

        if(s==e)
            printf("%d %d\n",++ca,ans+1);
        else
            printf("%d -1\n",++ca);
    }
    return 0;
}








POJ 3087 Shuffle'm Up(模拟),布布扣,bubuko.com

POJ 3087 Shuffle'm Up(模拟)

标签:des   style   http   color   os   io   strong   for   

原文地址:http://blog.csdn.net/u014737310/article/details/38614061

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!