码迷,mamicode.com
首页 > 其他好文 > 详细

B - Avoiding a disaster

时间:2014-08-19 12:24:34      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   for   

Description

bubuko.com,布布扣

Percy likes to be punctual. So much so that he always keeps three watches with him, so that he can be sure exactly what the time is. However, Percy‘s having a bad day. He found out that one of his watches was giving the wrong time. What‘s worse, when he went to correct the watch, he corrected the wrong one! That is, one watch was running x minutes behind (where xbubuko.com,布布扣480) and he wound one of the other watches x minutes forward. He now has three watches reading three different times, and hence is in serious danger of being tardy. Can you help Percy by writing a program that takes in the three times displayed on the watches and returns the correct time?

Input

The input begins with an integer T indicating the number of cases that follow ( 0 < T < 100). Each of the following T lines contains one test case, made up of three readings, separated by single space characters: H1:M1H2:M2H3:M3 In each reading H1, H2, H3 represent the hours displayed ( 0 < H1, H2, H3 < 13), and M1, M2, M3 represent the minutes displayed ( 0bubuko.com,布布扣M1, M2, M3 < 60).

If the number of minutes is less than 10, a leading 0 is perpended.

Output

For each test case, one line should be produced, formatted exactly as follows: "The correct time is Hi:Mi". If the number of minutes is less than 10, a leading 0 should be added. If the number of hours is less than 10, a leading 0 should NOT be added. If it is impossible to tell the time from the three readings, print the string: "Look at the sun".

Sample Input

3
5:00 12:00 10:00
11:59 12:30 1:01
12:00 4:00 8:00

Sample Output

The correct time is 5:00
The correct time is 12:30
Look at the sun

题意:时间 a b c 要求随意两个时间间隔相同 则输出中间的那个时间 否则输出 look at the sun
样例1 10 5 12 间隔分别是五
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <cstdlib>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <list>
#include <vector>
#include <iostream>
#include <algorithm>
#include <deque>
#include <ctime>
using namespace std;

int main()
{
   int n,i,j,t,m,a,b,h1,h2,h3;
   int num[5];
   while(~scanf("%d",&n))
   {
       while(n--)
       {
           for(i=0;i<3;i++)
           {
               scanf("%d:%d",&a,&b);
               num[i]=(a)*60+b;
           }
           sort(num,num+3);
           h1=num[1]-num[0];
           h2=num[2]-num[1];
           h3=num[0]-num[2]+720;
           //cout<<num[0]<<‘ ‘<<num[1]<<‘ ‘<<num[2]<<endl;
           //cout<<h1<<"  "<<h2<<"  "<<h3<<endl;
           if(h1==h2&&h2==h3)
                printf("Look at the sun\n");
           else if(h1==h2&&h1!=h3)
            printf("The correct time is %d:%02d\n",num[1]/60,num[1]%60);
           else if(h2==h3&&h2!=h1)
            printf("The correct time is %d:%02d\n",num[2]/60,num[2]%60);   ///%02d
           else if(h3==h1&&h3!=h2)
            printf("The correct time is %d:%02d\n",num[0]/60,num[0]%60);
            else
                 printf("Look at the sun\n");
       }
   }

   return 0;
}

 

B - Avoiding a disaster,布布扣,bubuko.com

B - Avoiding a disaster

标签:des   style   blog   http   color   os   io   for   

原文地址:http://www.cnblogs.com/zhangying/p/3921470.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!