码迷,mamicode.com
首页 > 其他好文 > 详细

[POJ] Bode Plot

时间:2017-01-17 23:26:59      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:sqrt   logs   name   term   pac   output   single   images   integer   

Description

Consider the AC circuit below. We will assume that the circuit is in steady-state. Thus, the voltage at nodes 1 and 2 are given by v1 = VS coswt and v2 = VRcos (wt + q ) where VS is the voltage of the source, w is the frequency (in radians per second), and t is time. VR is the magnitude of the voltage drop across the resistor, and q is its phase. 
技术分享

You are to write a program to determine VR for different values of w. You will need two laws of electricity to solve this problem. The first is Ohm‘s Law, which states v2 = iR where i is the current in the circuit, oriented clockwise. The second is i = C d/dt (v1-v2) which relates the current to the voltage on either side of the capacitor. "d/dt"indicates the derivative with respect to t. 

Input

The input will consist of one or more lines. The first line contains three real numbers and a non-negative integer. The real numbers are VS, R, and C, in that order. The integer, n, is the number of test cases. The following n lines of the input will have one real number per line. Each of these numbers is the angular frequency, w. 

Output

For each angular frequency in the input you are to output its corresponding VR on a single line. Each VR value output should be rounded to three digits after the decimal point.

Sample Input

1.0 1.0 1.0 9
0.01
0.031623
0.1
0.31623
1.0
3.1623
10.0
31.623
100.0

Sample Output

0.010
0.032
0.100
0.302
0.707
0.953
0.995
1.000
1.000

/*
一道无聊的数学题
推导出公式即可
*/
#include<iostream>
#include<cmath>
#include<stdio.h>
using namespace std;

int main()
{
	double vs, r, c;
	int n;
	cin>>vs>>r>>c;
	cin>>n;

	while(n-->0)
	{
		double w;
		cin>>w;

		double vr = r*c*w*vs*sqrt(1/(r*c*w*r*c*w+1));

		printf("%.3lf\n", vr);
	}

	return 0;
}

  

[POJ] Bode Plot

标签:sqrt   logs   name   term   pac   output   single   images   integer   

原文地址:http://www.cnblogs.com/KennyRom/p/6294944.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!