码迷,mamicode.com
首页 > 其他好文 > 详细

1013. Battle Over Cities (25)

时间:2017-01-18 15:08:49      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:oid   i++   line   max   ini   ems   ttl   bsp   using   

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input

3 2 3
1 2
1 3
1 2 3

Sample Output

1
0
0

/* 求在一个连通图中去掉一个节点后 需要至少添加几条边才能使剩下的节点连通  
   1. 用dfs求区域数  减1 即可。 去掉的那个节点将其visited[i]置为1 在dfs中通过该节点连接的节点就被分隔开来了。
*/
#include "iostream"
#include "cstring"
using namespace std;
#define MAX 1001
int map[MAX][MAX];
int visited[MAX];
int n, m, k;
void dfs(int j) {
    visited[j] = 1;
    for (int i = 1; i <= n; i++) {
        if (!visited[i] && map[j][i] == 1) {
            dfs(i);
        }
    }
}
int main() {
    cin >> n >> m >> k;
    while (m--) {
        int a, b;
        cin >> a >> b;
        map[a][b] = map[b][a] = 1;
    }
    while (k--) {
        int num = 0;
        int l;
        cin >> l;
        memset(visited, 0, sizeof(visited));
        visited[l] = 1;
        for(int i=1; i<=n; i++)
            if (!visited[i]) {
                dfs(i);
                num++;
            }
            cout << num - 1 << endl;
    }
    
    return 0;
}

 

1013. Battle Over Cities (25)

标签:oid   i++   line   max   ini   ems   ttl   bsp   using   

原文地址:http://www.cnblogs.com/minesweeper/p/6296729.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!